Page MenuHomePhabricator

Add support for language variant fallbacks for bold and italic buttons
Closed, ResolvedPublic

Description

Author: roigonzalezvilla10

Description:
In English language changed icon from bold and italic buttons by B and I, respectively. But for British and Canadian English language the icons weren't changed. I think that in British and Canadian English language should also change.

  • A (bold) -> B

(https://commons.wikimedia.org/wiki/File:Toolbaricon_bold_B.png)

  • A (italic) -> I

(https://commons.wikimedia.org/wiki/File:Toolbaricon_italic_I.png)


Version: unspecified
Severity: enhancement

Details

Reference
bz45864

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 1:28 AM
bzimport added a project: WikiEditor.
bzimport set Reference to bz45864.
bzimport added a subscriber: Unknown Object (MLST).

I think this should be done for all languages with variant, where the variant isn't configured explicitely, e.g. de-AT, de-CH, and de-formal should all use the same icons as de.

Modify wikiEditor.autoLang ? (modules/jquery.wikiEditor.js:167)

roigonzalezvilla10 wrote:

I think this should be done for all languages with variant, where the variant
isn't configured explicitely, e.g. de-AT, de-CH, and de-formal should all use
the same icons as de.

In accordance with Michael M.

For anybody interested in this, an example of a recent patch how to write a patch to use custom buttons can be found here:
https://gerrit.wikimedia.org/r/#/c/52641/1

Confirming buttons are different between en and en-CA.

GOIII claimed this task.Jun 25 2015, 2:19 AM
GOIII added a subscriber: GOIII.

I cannot reproduce the reported behavior. Assuming T87247 would have rectified this if not resolved already. Closing.

GOIII closed this task as Resolved.Jun 25 2015, 2:20 AM
GOIII set Security to None.
GOIII moved this task from Backlog to Closed on the WikiEditor board.Apr 3 2016, 9:47 AM