"Magic links" RFC, PMID and ISBN should be configurable and disableable
Closed, ResolvedPublic

Description

(this part is about a bug)
Forcing magic links for RFC, ISBN and PMID without simple way to disable it through configuration can't be seen as anything other than a bug.

it is clear that the changing the default behavior will create a serious regression, so the default behavior should be exactly as today. however, not allowing to disable these magic links through config is a bug. i might not want my wiki to link to either of these external sites.

(this part is about enhancement)
moving it to configuration, if done correctly, will also allow sites to expand to other magic words, such as bugzilla entries for the project this wiki is used for, or patent#, or court ruling etc.

each of these may be more relevant or more appropriate in some specific wiki than RFC or ISBN or PMID.

unfortunately i can't add a patch to this ticket (maybe i will, eventually, if nobody else will), but the idea is to use something like $wgAutoMagicLinks array that will receive a value in DefaultSettings.php that will create the current behavior, and the user will be able to override in LocalSettings.php, for both removing unwanted automagiclinks (some or all), and add new ones.

again, the ability to have new ones is "nice to have", but not being able to suppress the hardcoded ones through config is nothing less than a bug.

peace.


Version: 1.25-git
Severity: enhancement
Whiteboard: usability
See Also:

Details

Reference
bz45942
bzimport raised the priority of this task from to Low.
bzimport set Reference to bz45942.
bzimport added a subscriber: Unknown Object (MLST).
Kipod created this task.Mar 9 2013, 8:18 PM
Kipod added a comment.Mar 11 2013, 3:45 PM

hashar changed the classification from "bug" to "enhancement".

although i agree that doing it in a way that will allow adding new "magic links", or even in a way that will allow controlling magic links individually may be considered "enhancement", i disagree that not being able to disable magic links in any manner can be considered anything other than "bug".

the absolute minimum that's required in order for the implementation of this feature not to be considered a bug, is to create a single configuration variable that will be assigned the value "true" in DefaultSettings, and will gate the magic links expansion procedure.

keeping legacy perversions for backward compatibility is the right thing to do. not providing for a way to disable those perversions (short of editing core) is plain and simple bug. maybe it's a low priority bug, but it's _not_ "enhancement".

peace.

I 2nd the request from the title without reading the posts. These auto links are not useful for everyone.

MediaWiki is not WikiPedia!

Ricordisamoa added a subscriber: Ricordisamoa.
He7d3r updated the task description. (Show Details)Jun 9 2015, 11:50 PM
He7d3r set Security to None.
Jbribeiro1 added a subscriber: Jbribeiro1.

For what it's worth, I think the Parser team agrees and feels like RFC/PMID/ISBN are just old backwards-compatibility baggage that we'd like to get rid of. They are not localizable, etc. Auto-linking ISBNs and the like could easily be done in Visual Editor when they are created, or via a template.

But migrating all our existing content to use templates (or whatever) instead of autolinks will be a long process, and we need to do this before we can remove the magic link code from mediawiki.

Subfader added a comment.EditedJun 10 2015, 7:10 PM

Use an extension. MediaWiki is NOT Wikipedia.

I agree with deprecating this functionality and disabling it for new installs (both WMF-hosted wikis and otherwise) or at least moving it out into an extension. That's basically what this task is suggesting - not removing the code entirely yet.

What about mediawiki/extensions/MagicLinks then?

I 2nd the request from the title without reading the posts. These auto links are not useful for everyone.

Are they harmful for someone?

I 2nd the request from the title without reading the posts. These auto links are not useful for everyone.

Are they harmful for someone?

They could (especially in a third-party MediaWiki where users are unfamiliar with this feature) link to the wrong thing, which would be misleading. RFC 3 in free text does not necessarily refer to https://tools.ietf.org/html/rfc3 . Many organizations have Requests for Comments of various types.

I 2nd the request from the title without reading the posts. These auto links are not useful for everyone.

Are they harmful for someone?

Are they helpful to anyone?

Harmful or not, at least disabling them should be easier.

Are they helpful to anyone?

Clearly yes, as people are using them actively and there is always activity around Special:BookSources etc.

Subfader added a comment.EditedJun 28 2015, 11:31 AM

Are they helpful to anyone?

Clearly yes, as people are using them actively and there is always activity around Special:BookSources etc.

Not on my wiki... But I do have stupid auto links generated out of nothing...

A global option to disable them would be the least imo.

Are they helpful to anyone?

Clearly yes, as people are using them actively and there is always activity around Special:BookSources etc.

Simply replacible by one bot pass i. e. by doing the change like "ISBN <regex>" -> "[[Special:BookSources/regex|ISBN regex]]" and so on.
I'm pretty sure some maintenance script for that could be done as well...


Just a mindflow:

We have interwikis, so why don't we use [[pmid:...]] [[isbn:...]] and something reasonable for RFC (3-letter combinations MUST NOT be used due to possible collision with language code, even though unused ATM, which rfc is).

And from Wikimedia perspective:
If the solution would be by the interwiki, it MUST be configurable per site, not globally, as typically different languages would like to link to different external databases.

Which actually leads to another suggestion:
Interwikis might not be that flexible, so we can use {{#isbn:}} {{#pmid:}} {{#rfc:}} (or more generic like {{#sources:isbn|9781234567890}} which would link to by MW messages configurable special page (unlike the current Special:BookSources, which has the (often obsolete) stuff hardcoded in PHP langfile).

Which actually reminds me my ancient proposal T12867: Create Special:Sources and {{#sources:}}...

Scott added a comment.May 26 2016, 2:17 PM

Copied comment from over there: adding as a blocked task because if the magic linking code is going to be addressed it should be done properly, rather than a hacky workaround in the notifications code.

I suppose the first step would be to create a ParserOption to control this.

Legoktm renamed this task from "Magic links" RFC, PMID and ISBN must be configurable and disableable to "Magic links" RFC, PMID and ISBN should be configurable and disableable.May 26 2016, 6:33 PM
jayvdb added a subscriber: jayvdb.Jul 2 2016, 12:10 PM

Change 309528 had a related patch set uploaded (by Legoktm):
Parser: Allow disabling magic link functionality

https://gerrit.wikimedia.org/r/309528

The other day I intentionally used a RFC magic link for the first time, and that reminded me of this bug.

MW 1.27 and this crap is still core code.

Change 310209 had a related patch set uploaded (by Legoktm):
Handle magic links being disabled

https://gerrit.wikimedia.org/r/310209

Change 309528 merged by jenkins-bot:
Parser: Allow disabling magic link functionality

https://gerrit.wikimedia.org/r/309528

Legoktm closed this task as Resolved.Sep 13 2016, 9:06 AM
Legoktm claimed this task.

There will be some follow-up needed in extensions (Scribunto, VE, etc.), but the core part of this task is resolved.

MW 1.27 and this crap is still core code.

Thanks, your comment was extremely helpful in resolving this issue.

He7d3r added a subscriber: He7d3r.Sep 14 2016, 11:58 AM
Subfader removed a subscriber: Subfader.Sep 14 2016, 6:43 PM