Page MenuHomePhabricator

Clarify the right "unwatchedpages" ([[MediaWiki:Right-unwatchedpages]])
Closed, InvalidPublic

Description

Some app on the toolserver have had this function ,which if add your username on the whitelist and pass the authentication on the toolserver to make sure you're the user on Wikipedia's project, then you can watch the watchers' count of the page which the watcher of the page lower 30 people.

I hope add this function on the mediawiki sofeware.This function like that:
A right can permit the user can watch the watchers' count of the page which the watcher of the page lower 30 people. Administrator have had this right,autoconfirmed or confirmed user can ask administrator to give the right.

That's my suggestions,and please forgive my bad English.


Version: 1.21.x
Severity: minor

Details

Reference
bz46015

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 1:38 AM
bzimport added a project: MediaWiki-General.
bzimport set Reference to bz46015.
bzimport added a subscriber: Unknown Object (MLST).
Cwek created this task.Mar 12 2013, 6:52 AM

This functionality is attached to the "unwatchedpages" user right. By default, only administrators have this user right. However, it's perfectly possibly to add a custom user group with this user right.

On which wiki would you like to be able to see the number of page watchers?

Cwek added a comment.Mar 12 2013, 7:19 AM

(In reply to comment #1)

This functionality is attached to the "unwatchedpages" user right. By
default,
only administrators have this user right. However, it's perfectly possibly to
add a custom user group with this user right.
On which wiki would you like to be able to see the number of page watchers?

You means that If the user have the "unwatchedpages" user right,he can watch
the watchers' count of the page at the page of page information which the watcher of the page lower 30 people but more than 0,is it? I thought that the "unwatchedpages" user right can make the user watch the page which none wachted at the special page.

And I hope this functionality can be the part of mediawiki software.Not just at some wikiproject.

(In reply to comment #2)

You means that If the user have the "unwatchedpages" user right,he can watch
the watchers' count of the page at the page of page information which the
watcher of the page lower 30 people but more than 0,is it?

Yes: bug 39957.

So this turns out to be a wording issue, causing the original reporter's misunderstanding of this user right.

Cwek added a comment.Mar 12 2013, 10:50 AM

Maybe I don't want to change the definition of "unwatchedpages" because I don't want that the user who not the administrator can see the Special:Unwatchedpages page.Just the user with a right or right group can see the count of page watched by between 1 and $wgUnwatchedPageThreshold at the action of page info.Maybe the user right group is a good resolution,but because this's just my idea without any common consensus yet,I don't sure that it's good enough to add a new user group and anyone think that it's helpful.

(In reply to comment #5)

Maybe I don't want to change the definition of "unwatchedpages" because I
don't
want that the user who not the administrator can see the
Special:Unwatchedpages
page.Just the user with a right or right group can see the count of page
watched by between 1 and $wgUnwatchedPageThreshold at the action of page
info.Maybe the user right group is a good resolution,but because this's just
my
idea without any common consensus yet,I don't sure that it's good enough to
add
a new user group and anyone think that it's helpful.

It doesn't make sense. In your design ordinary users can iterate over action=info of all pages, and write down the title of every page they see which has no watcher, to compose their own Special:UnwatchedPages.

Cwek added a comment.Mar 13 2013, 12:35 AM

(In reply to comment #6)

(In reply to comment #5)

Maybe I don't want to change the definition of "unwatchedpages" because I
don't
want that the user who not the administrator can see the
Special:Unwatchedpages
page.Just the user with a right or right group can see the count of page
watched by between 1 and $wgUnwatchedPageThreshold at the action of page
info.Maybe the user right group is a good resolution,but because this's just
my
idea without any common consensus yet,I don't sure that it's good enough to
add
a new user group and anyone think that it's helpful.

It doesn't make sense. In your design ordinary users can iterate over
action=info of all pages, and write down the title of every page they see
which
has no watcher, to compose their own Special:UnwatchedPages.

I see.I think MZMcBride's design is nice.But I'm not sure that add a new user group with "unwatchedpages" right is good or helpful because I don't know how many user who not the administrator need to watch the count of the page less 30 watchers.Would it make the administrator confused?

Cwek closed this task as Invalid.Mar 23 2017, 1:52 AM

I close. because some op saids it will be easier to use for vandalism by someone who defraud the trust from the admins.

Restricted Application removed a subscriber: Liuxinyu970226. · View Herald TranscriptMar 23 2017, 1:52 AM
Cwek removed a project: I18n.Mar 23 2017, 1:53 AM