Page MenuHomePhabricator

MediaWiki:Donate interface-error-msg-field-correction not properly translatable due to several grammatical genders
Closed, ResolvedPublic

Description

This bug is refering to [[MediaWiki:Donate interface-error-msg-field-correction]] message. Thread copied from http://translatewiki.net/wiki/Thread:Translating_talk:MediaWiki/About_MediaWiki:Donate_interface-error-msg-field-correction/en

There are some problems with this message due to gender issues. Parameter may $1 take many values. This values are words that take different genders in some languages. For example (for Galician):
:$1 = first name (nome) → Por favor, corrixe os erros '''no teu''' $1.
:$1 = city (cidade) → Por favor, corrixe os erros '''na túa''' $1.
And so on.


Version: wmf-deployment
Severity: normal

Details

Reference
bz46395

Related Objects

View Standalone Graph
This task is connected to more than 200 other tasks. Only direct parents and subtasks are shown here. Use View Standalone Graph to show more of the graph.

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 1:35 AM
bzimport set Reference to bz46395.
bzimport added a subscriber: Unknown Object (MLST).
Tolino created this task.Mar 21 2013, 12:07 AM

I don't completely understand the problem yet (sorry) - could you provide a concrete example which has problems?

Parameter $1 may take many values. For example: $1 can be "donation amount", "email address", "first name", "last name"... (complete list at http://translatewiki.net/w/i.php?title=MediaWiki:Donate_interface-error-msg-field-correction/qqq&oldid=4586899)

The problem is that translation may vary depending on the value of $1. In Galician, for example, the message can take to wordings:
*Por favor, corrixe os erros no teu $1
*Por favor, corrixe os erros na túa $1

Being one or another depends on the grammatical gender of the word which will be shown instead of "$1". Example:
*Por favor, corrixe os erros no teu nome ($1 = name)
*Por favor, corrixe os erros na túa cidade ($1 = city)

I can't provide a concrete example, because I would have to specify the phrase with all the possible values for $1.

Ah, thanks a lot for explaining, understood now.

I have translated the message as follows:

Please correct the errors in the following field: $1

I think that the meaning is not lost and we just skip the problem. Maybe it would be a good idea to add this suggestion in the documentation to help other users.

Hey @Tolino am I reading this right that you were able to resolve it?

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 30 2015, 11:08 PM
Tolino added a comment.Aug 1 2015, 5:24 PM

The workaround that I explained in my previous message (slightly changing the message definition) avoids the problem.

So you can mark this bug as resolved, I suppose.

atgo closed this task as Resolved.Aug 3 2015, 8:52 PM
atgo claimed this task.

Thanks @Tolino!