Distinguish links to redirect pages on Special:Watchlist
Closed, DeclinedPublic

Description

Author: netoholic

Description:
Redirects currently appear as normal links on the watchlist. Could these
be altered so that they appear in italics, or some other different way?


Version: unspecified
Severity: enhancement
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=890

bzimport added a subscriber: wikibugs-l.
bzimport set Reference to bz2872.
bzimport created this task.Via LegacyJul 15 2005, 9:39 PM
brion added a comment.Via ConduitJul 15 2005, 11:14 PM

See also bug 759 etc.

bzimport added a comment.Via ConduitJul 16 2005, 4:52 PM

zigger wrote:

*** This bug has been marked as a duplicate of 759 ***

bzimport added a comment.Via ConduitJul 16 2005, 5:16 PM

zigger wrote:

(Undoing resolution as duplicate.)

Requests for rendering of redirection links differently from other links:

  • bug 759 - on watchlist edit pages
  • bug 2318 - on Special:Allpages
  • bug 2814 - on Special:Disambiguations
  • bug 2872 (this bug) - on Special:Watchlist

and bug 890 requests that redirection links on Special:Watchlist (&
Recentchanges & Recentchangeslinked) not automatically redirect.

bzimport added a comment.Via ConduitNov 4 2005, 11:50 AM

gangleri wrote:

see bug 2318 comment 8 Special:Allpages should mark redirects distinctly
( http://bugzilla.wikimedia.org/show_bug.cgi?id=2318#c8 )
patch from http://mail.wikipedia.org/pipermail/mediawiki-cvs/2005-July/010231.html

If italic is not suitable for some writing sysmtems / fonts one could use a
special background. The "color" could be defined in MediaWiki messages or
Monobook.css or ...

yi:wiktionary will have probably more then 50% redirects doe to romanization /
transliteration and derived forms. This is why a "smart" Special:Allpages would
be required.

Regards Reinhardt [[user:gangleri]]

bzimport added a comment.Via ConduitNov 12 2005, 6:12 PM

gangleri wrote:

(In reply to comment #3)

(Undoing resolution as duplicate.)

Requests for rendering of redirection links differently from other links:

  • bug 759 - on watchlist edit pages
  • bug 2318 - on Special:Allpages
  • bug 2814 - on Special:Disambiguations
  • bug 2872 (this bug) - on Special:Watchlist

    and bug 890 requests that redirection links on Special:Watchlist (& Recentchanges & Recentchangeslinked) not automatically redirect.

see also
bug 3941 &redirect=no should mark redirects distinctly (doubl, multiple
redirects and redirects to itself)

bzimport added a comment.Via ConduitFeb 20 2007, 6:30 PM

ligulem wrote:

See also bug 8888 - on list of transcluded pages

siebrand added a comment.Via ConduitFeb 2 2009, 11:42 AM

Changing component to "Watchlist"

Withoutaname added a comment.Via ConduitApr 26 2014, 7:43 PM

Is there any consensus for this change? I'd imagine some people might be irked when they see some entries on their Watchlist italicized and have no idea what that means.

Qgil added a comment.Via ConduitApr 30 2014, 6:01 AM

For what is worth, WhatLinksHere adds "(redirect page)". I'm not a designer, but I would say that you can't go too wrong using consistently the same approach. Also, the string is already available and translated.

Example: https://en.wikipedia.org/wiki/Special:WhatLinksHere/R_v_Betts_and_Ridley

XXN added a comment.Via ConduitNov 20 2014, 12:14 AM

I don't have any objections with redirects being in italics.
But i suggest to add other distinctive elements in DOM for redirects to make it possible to create userscripts which will check automatically all redirect items to make it easier to remove at once all redirects from wathclist.

XXN raised the priority of this task from "Low" to "Normal".Via WebJan 1 2015, 4:03 PM
XXN set Security to None.
Glaisher added a subscriber: Glaisher.Via WebJan 1 2015, 4:15 PM

Something like r next to the page name with a tooltip saying "This page is a redirect". This is the way it currently appears for bot/minor/unpatrolled edits.

Nemo_bis closed this task as "Declined".Via WebJan 16 2015, 9:33 PM
Nemo_bis claimed this task.
Nemo_bis added a subscriber: Nemo_bis.

This would be pointless noise. Edits to redirects are rare (http://mako.cc/copyrighteous/consider-the-redirect ) and can't be assumed to be less or more important than any other edit.

Special:AllPages puts redirects in italics because they are not "real pages"; Special:WhatLinksHere because they are not true incoming links, but only a way for other pages to give incoming links; but edits are edits.

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.