Page MenuHomePhabricator

Using <tvar|> at the translatable subpages
Closed, ResolvedPublic

Description

With using <tvar|> at the translatable subpages, "tvar" markup is copied in the /en subpage.

See actual example:

  1. last section ("T:3") of the http://www.wikidata.org/wiki/Wikidata:Notability/Exclusion_criteria
  1. These same string in the http://www.wikidata.org/wiki/Wikidata:Notability/Exclusion_criteria/en (bad behaviour; redundant markup)
  1. Compare with http://www.wikidata.org/wiki/Wikidata:Notability/Exclusion_criteria/ru (good behaviour; no markup)

With using in the "usual" pages (not be a subpages), this worked correctly.


Version: master
Severity: normal

Details

Reference
bz46925

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 1:16 AM
bzimport set Reference to bz46925.
bzimport added a subscriber: Unknown Object (MLST).
Kaganer created this task.Apr 5 2013, 12:34 PM

Related URL: https://gerrit.wikimedia.org/r/60648 (Gerrit Change Ie822dbf36de82c6b206b28492942b62e73022257)

Patch fixes this issue. Merging. Will most probably be deployed to Wikimedia
wikis in 1.22wmf3

https://gerrit.wikimedia.org/r/60648 (Gerrit Change Ie822dbf36de82c6b206b28492942b62e73022257) | change APPROVED and MERGED [by jenkins-bot]

tomasz added a comment.Jul 8 2013, 8:10 PM

This occurred again today: https://meta.wikimedia.org/w/index.php?title=Tech/News/2013/28/en&diff=prev&oldid=5637830, breaking this week's issue of Tech News.

That edit is especially interesting, since it was caused by me closing previously unclosed italics (''lazyfox'') and not mingling with the <tvar> itself: https://meta.wikimedia.org/w/index.php?title=Tech/News/2013/28&diff=5637825&oldid=5637218

Seb35 added a comment.Jan 13 2014, 9:35 AM
  • Bug 53932 has been marked as a duplicate of this bug. ***
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 23 2016, 8:04 AM

This has not been reproduced for several years;)
This task may be closed.

Kaganer closed this task as Resolved.Oct 5 2017, 2:50 PM

Thanks for checking!