UW hangs on upload in some circumstances
Closed, DeclinedPublic

Description

Firefox only

See discussion at https://commons.wikimedia.org/wiki/Commons:Upload_help#.22Special:UploadWizard.22_seems_stuck

I have been unable to reproduce this when uploading files manually, nor have I seen this in any environment other than beta cluster commons.

When running the automated test for UW for Firefox only against beta commons, UW starts to upload a .png file, the thumbnail is there, but the upload never completes.

Error Console shows the message

Timestamp: 04/18/2013 01:37:53 PM
Error: TypeError: result is null
Source File: http://commons.wikipedia.beta.wmflabs.org/w/load.php?debug=false&lang=en&modules=ext.uploadWizard&skin=vector&version=20130412T222614Z&*
Line: 109

I am not completely sure that the production issue and the browser test issue are related, but it seems possible at least.


Version: unspecified
Severity: major

Details

Reference
bz47384
bzimport set Reference to bz47384.
bzimport added a subscriber: Unknown Object (MLST).
Cmcmahon created this task.Apr 18 2013, 8:57 PM

Thanks Andre for that link. I doubt if this problem is due to some FF plugin or because of some deprecated properties in FF as looks at https://commons.wikimedia.org/wiki/User:Godot13/Sandbox/Upload_Wizard_problem (the error log)

I have uploaded a lot of images in the last hour or so using Firefox 20.0 and commons.wikimedia.org and I could not reproduce the problem. Everything worked just fine.

Should we close the bug? As far as I understood "Commons:Upload help" the reported also said everything works fine for him now.

seems to have overtaken by history

Gilles moved this task from Untriaged to Done on the Multimedia board.

Add Comment