Page MenuHomePhabricator

VisualEditor: Reopening page in VE immediately after saving page in VE loads old version
Closed, ResolvedPublic

Description

(a) open a page in VE and edit it
(b) save in VE
(c) reopen the same page right away in VE

The previous version (rather than saved version) is fetched. I looked at POST params in chrome and looks like revision id (oldid) being sent is of the older version rather than the saved version.


Version: unspecified
Severity: normal

Details

Reference
bz47420

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:20 AM
bzimport set Reference to bz47420.
ssastry created this task.Apr 19 2013, 5:51 PM

Feels like we need to properly review how the integration around oldids works, given the number of issues. :-(

This is because we don't update this.oldid after saving.

The JSON we get back after a save only contains the plain html and some timestamps. In order for us to update this.oldid we'll need Parsoid to tell us what it is, I think.

(In reply to comment #3)

The JSON we get back after a save only contains the plain html and some
timestamps. In order for us to update this.oldid we'll need Parsoid to tell
us what it is, I think.

Parsoid doesn't know; it's VisualEditor.php which does the actual saving to the DB.

Related URL: https://gerrit.wikimedia.org/r/62168 (Gerrit Change I12ce27c8dc57f7aa753bcf5840635d5fea6b4e80)

Now merged and will go into wmf4.

  • Bug 47682 has been marked as a duplicate of this bug. ***
  • Bug 48021 has been marked as a duplicate of this bug. ***

This bug was closed as fixed on May 3 but I am still seeing this behavior on mediawiki.org. The second edit after saving loads the previous version of the page, not the current version. A warning "You are editing an out-of-date revision of this page" appears, but that doesn't help.

Re-closing; new breakage is being tracked as bug 47420.

That is bug 50441.

(In reply to comment #11)

That is bug 50441.

Yes; sorry! :-)