Page MenuHomePhabricator

File history for videos showing wrong (same as first version) information for later versions
Closed, ResolvedPublic

Description

I'm not sure if this may be a TMH bug (not had chance to triage it further as my dev wiki won't let me login), but it seems that when uploading new versions of a file, the prior version is shown in the file history.

I uploaded the originals and the replacements via importImages.php to commons

https://commons.wikimedia.org/wiki/File:British_Airways_Airbus_A320-200_G-EUUJ_BA1372_Take_off_from_London_Heathrow_2013-03-20.ogg

https://commons.wikimedia.org/wiki/File:British_Airways_Boeing_747-436_G-CIVT_BA284_Landing_at_London_Heathrow_2013-03-20.ogg

In the file history table, both rows show the same time, date, resolution and dimensions.

I know for a fact that they are different, and it can be confirmed by downloading the files

https://commons.wikimedia.org/wiki/File:British_Airways_Boeing_747-436_G-CIVT_BA284_Landing_at_London_Heathrow_2013-03-20.ogg

rev 1 is 155MB, rev 2 is 146MB. Similar can be seen on the other video.

It would seem that the Date/Time, dimensions and comment are using the wrong version. Thumbnails would look correct (see rotation on 747 video)


Version: unspecified
Severity: normal

Details

Reference
bz47483

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:25 AM
bzimport added a project: TimedMediaHandler.
bzimport set Reference to bz47483.
Reedy created this task.Apr 21 2013, 9:21 PM
Reedy added a comment.Apr 21 2013, 9:23 PM

reedy@ubuntu64-web-esxi:~$ curl --head https://upload.wikimedia.org/wikipedia/commons/e/e0/British_Airways_Boeing_747-436_G-CIVT_BA284_Landing_at_London_Heathrow_2013-03-20.ogg
HTTP/1.1 200 OK
Server: nginx/1.1.19
Date: Sun, 21 Apr 2013 21:23:11 GMT
Content-Type: application/ogg
Content-Length: 153122901
Connection: keep-alive
X-Object-Meta-Sha1base36: 24o19so5k997p7098flv1p0rqdxykos
Last-Modified: Sun, 21 Apr 2013 19:15:38 GMT
Etag: e1f5fbde565b062845865e1895fdf54c
X-Timestamp: 1366571738.35156
X-Varnish: 980397808, 2065288127 2043628637, 2805724975
Via: 1.1 varnish, 1.1 varnish, 1.1 varnish
Accept-Ranges: bytes
Age: 7532
X-Cache: cp1034 miss (0), cp3006 hit (21), cp3008 frontend miss (0)
Access-Control-Allow-Origin: *

reedy@ubuntu64-web-esxi:~$ curl --head https://upload.wikimedia.org/wikipedia/commons/archive/e/e0/20130421191426%21British_Airways_Boeing_747-436_G-CIVT_BA284_Landing_at_London_Heathrow_2013-03-20.ogg
HTTP/1.1 200 OK
Server: nginx/1.1.19
Date: Sun, 21 Apr 2013 21:23:26 GMT
Content-Type: application/ogg
Content-Length: 162426826
Connection: keep-alive
X-Object-Meta-Sha1base36: 9027l843y94wiqc3z5i9evceyvw08jb
Last-Modified: Sun, 21 Apr 2013 19:14:27 GMT
Etag: c4f8e0728333afb73b36d4c71690f51b
X-Timestamp: 1366571667.71563
X-Varnish: 1809238161, 1073164668 1072399915, 2205251933
Via: 1.1 varnish, 1.1 varnish, 1.1 varnish
Accept-Ranges: bytes
Age: 419
X-Cache: cp1033 miss (0), cp3009 hit (4), cp3010 frontend miss (0)
Access-Control-Allow-Origin: *

reedy@ubuntu64-web-esxi:~$

Reedy added a comment.Apr 21 2013, 9:44 PM

PNG test https://commons.wikimedia.org/wiki/File:Reedy_lol_test_file.png

Would hence seem to be fine in core MW. Suspecting TMH or importImages more specifically now..

Reedy added a comment.Apr 21 2013, 9:47 PM

ImportImages tested locally with no TMH. Files history displays correctly

jgerber wrote:

upload new version on the Files page looks ok, so this must be caused by ImportImages not using the same api.

Related URL: https://gerrit.wikimedia.org/r/60249 (Gerrit Change I0e879604ce76ed78708a36df46b58fb3b8a7d6d2)

https://gerrit.wikimedia.org/r/60249 (Gerrit Change I0e879604ce76ed78708a36df46b58fb3b8a7d6d2) | change APPROVED and MERGED [by jenkins-bot]

Gerrit patch got merged, can this bug report get closed as RESOLVED FIXED or is there anything else to do?

Gilles raised the priority of this task from High to Unbreak Now!.Dec 4 2014, 10:21 AM
Gilles moved this task from Untriaged to Done on the Multimedia board.
Gilles lowered the priority of this task from Unbreak Now! to High.Dec 4 2014, 11:22 AM