Page MenuHomePhabricator

VisualEditor: In RTL, the "Edit" tab appears down-tab (to the left) rather than up-tab (to the right) of "Edit source"
Closed, ResolvedPublic8 Story Points

Description

The order should be Edit then Edit tab. Looks like a hard-coded left somewhere?

Details

Reference
bz48017

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:33 AM
bzimport set Reference to bz48017.

This is caused by bug 46947 – the HTML order of tabs is reversed, then reversed again in the CSS...

Related URL: https://gerrit.wikimedia.org/r/63153 (Gerrit Change Ie1214b08450aefed893739a2b862cb1e9b23a2ef)

Merged into master.

  • Bug 47684 has been marked as a duplicate of this bug. ***
matmarex reopened this task as Open.Sep 28 2017, 5:34 AM

With the underlying issue T48947 being fixed, our workaround is now unnecessary and in fact reintroduces this issue. We should remove it.

Change 381167 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] ve.init.mw.DesktopArticleTarget: Remove hack for reversed tabs in RTL in Vector

https://gerrit.wikimedia.org/r/381167

(This will need to be backported to 1.31.0-wmf.1.)

Change 381167 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] ve.init.mw.DesktopArticleTarget: Remove hack for reversed tabs in RTL in Vector

https://gerrit.wikimedia.org/r/381167

Change 381210 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@wmf/1.31.0-wmf.1] ve.init.mw.DesktopArticleTarget: Remove hack for reversed tabs in RTL in Vector

https://gerrit.wikimedia.org/r/381210

Change 381210 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@wmf/1.31.0-wmf.1] ve.init.mw.DesktopArticleTarget: Remove hack for reversed tabs in RTL in Vector

https://gerrit.wikimedia.org/r/381210

Mentioned in SAL (#wikimedia-operations) [2017-09-28T13:38:12Z] <zfilipin@tin> Synchronized php-1.31.0-wmf.1/extensions/VisualEditor/modules/ve-mw/init/targets/ve.init.mw.DesktopArticleTarget.init.js: SWAT: [[gerrit:381210|ve.init.mw.DesktopArticleTarget: Remove hack for reversed tabs in RTL in Vector (T50017)]] (duration: 00m 50s)

matmarex closed this task as Resolved.Sep 28 2017, 1:50 PM

After trying to verify the fix during the SWAT deployment, I found out that this entire feature (fixing up the tab order if wgVisualEditorTabPosition was changed and we're seeing cached HTML with the tabs in wrong order) is actually entirely broken and just does nothing. The deployment was essentially a no-op. This is actually convenient because had it worked, it would have been messing up the tabs.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptSep 28 2017, 1:50 PM

Change 381217 had a related patch set uploaded (by Bartosz Dziewoński; owner: Bartosz Dziewoński):
[mediawiki/extensions/VisualEditor@master] ve.init.mw.DesktopArticleTarget: Fix the code to reorder tabs

https://gerrit.wikimedia.org/r/381217

Change 381217 merged by jenkins-bot:
[mediawiki/extensions/VisualEditor@master] ve.init.mw.DesktopArticleTarget: Fix the code to reorder tabs

https://gerrit.wikimedia.org/r/381217

Jdforrester-WMF updated the task description. (Show Details)
Jdforrester-WMF set the point value for this task to 8.