Page MenuHomePhabricator

New edit section link left of heading due to stale parser cache interacting with $wgUseTidy
Closed, DeclinedPublic

Description

Wrong side

For some reason, on some pages the new edit section link is near the header, but on the wrong side, see screenshot (same on Vector logged out).

Steps to reproduce: unknown. Perhaps an interaction with the template above and its language magic.


Version: 1.22.0
Severity: trivial
URL: https://meta.wikimedia.org/wiki/User_talk:Johnlong

Attached:

Details

Reference
bz48046

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 1:36 AM
bzimport set Reference to bz48046.
bzimport added a subscriber: Unknown Object (MLST).
Nemo_bis created this task.May 3 2013, 1:18 PM

I have specifically hacked in a fix for this :/

Also, it happened just on one heading on a page? That's mad.

Seems to be caused by $wgUseTidy being teh suck. The <span style=...> is interspersed with the <h2> in resulting HTML, confusing the hacky regex I'm using to wrestle old cached parser renders into the shape required by new links.

I'm inclined to WONTFIX this. action=purge will fix the issue, and this should be a rare occurrence.

(In reply to comment #2)

I'm inclined to WONTFIX this. action=purge will fix the issue, and this
should
be a rare occurrence.

Yes, makes sense to WONTFIX if it's just temporary. I expected to be slapped an INVALID for some evil hack used by Meta, so I'm happy. :)

WONTFIX it is, then.