VisualEditor: Support pasting of HTML from external sources
Closed, ResolvedPublic

Description

many + signs

Tested:

In OpenOffice, create a small table with text in cells a1, a2, b1, b2, c2.

Copy only the rows of the table.

Paste into VE.

  • the view immediately in VE is of unusable information and some "+" characters apparently indicating cell boundaries.

Version:1.0StartHTML:0000000155EndHTML:0000000881StartFragment:0000000475EndFragment:0000000864➞➞➞➞➞➞➞➞➞➞➞➞➞a1➞➞➞b1➞➞➞➞➞➞➞➞➞➞a2➞➞➞b2➞➞➞c2➞➞➞

  • the view in the "Review your changes" panel is of a swath of white space with the contents of the table interspersed.
  • User tendency is to copy entire contents of rows, yielding many empty cells. VE dutifully tracks these empty cells and displays an enormous number of "+" symbols in the immediate view and mostly empty space in the "Review your changes" view.
  • Upon save, no table is in the page when pasting from OpenOffice.

Other anomalous results are reported when pasting from the Apple Pages application. From another user:

"...number of cells didn't match the number of columns. Since they don't match, tried to delete the cells in order to recover the blank page, but they won't delete."


Version: unspecified
Severity: normal

Attached:

bzimport set Reference to bz48170.
Cmcmahon created this task.Via LegacyMay 6 2013, 6:50 PM
Catrope added a comment.Via ConduitMay 6 2013, 6:56 PM
  • Editing of table structure isn't exactly supported right now
  • I'm curious what OpenOffice puts on the clipboard. It may well be that the root cause is "OpenOffice puts unreasonable things on the clipboard when copying a table"
Cmcmahon added a comment.Via ConduitMay 6 2013, 7:12 PM

I think users will expect that pasting things like tables from other editors and sources into VE to more or less Just Work.

Jdforrester-WMF added a comment.Via ConduitMay 6 2013, 9:10 PM

(In reply to comment #2)

I think users will expect that pasting things like tables from other editors
and sources into VE to more or less Just Work.

That is bug 41193 (and yes, getting that to work would be lovely). This is about corruption of the clipboard from OpenOffice, which is a distinct problem whether or not we get the pasted-formatting working in time for the 'beta'.

gerritbot added a comment.Via ConduitOct 7 2013, 2:52 PM

Change 86664 had a related patch set uploaded by Esanders:
Rich paste

https://gerrit.wikimedia.org/r/86664

gerritbot added a comment.Via ConduitNov 26 2013, 9:07 PM

Change 86664 merged by jenkins-bot:
Rich paste

https://gerrit.wikimedia.org/r/86664

Jdforrester-WMF set Security to None.

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.