Page MenuHomePhabricator

Error creating thumbnail: "Warning: File has insufficient data for an image."
Closed, ResolvedPublic

Description

After uploading a particular pdf file (of size 4MB) the message

"Error creating thumbnail:

  • Warning: File has insufficient data for an image."

appears, where the "warning" line is repeated 5 times. The message closes with "convert: missing an image filename `[...]/images/tmp/transform_[...]-1.jpg'."
However, if I click on "Full resolution", the pdf file can be displayed by firefox/acroread. But there is no thumbnail/preview.

What could be the reason for this? (What do I have to do to isolate the problem?)

Other pdf files don't make such problems.


Version: unspecified
Severity: normal
OS: Linux
Platform: PC

Details

Reference
bz48178

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 1:15 AM
bzimport set Reference to bz48178.
bzimport added a subscriber: Unknown Object (MLST).

Can you provide a copy of the file for testing? Otherwise it's somewhat stabbing in the dark

I understand that, but unfortunately I'm not allowed to do that. Maybe I can ask the user to generate a similar pdf but filled with whitespace.

pdfinfo said:
Creator: Adobe InDesign CS5.5 (7.5)
Producer: Adobe PDF Library 9.9
CreationDate: Fri Jan 4 15:44:24 2013
ModDate: Fri Jan 4 15:44:37 2013
Tagged: yes
Pages: 1
Encrypted: no
Page size: 1683.78 x 2383.94 pts
File size: 4229845 bytes
Optimized: yes
PDF version: 1.4

(In reply to comment #2)

I understand that, but unfortunately I'm not allowed to do that. Maybe I can
ask the user to generate a similar pdf but filled with whitespace.

If you can still duplicate the error on that file, that would be fine

pdf file that can't be previewed by pdfhandler extension

ok, here's an example file that leads to such an error.

Attached:

seth: Which MediaWiki version is this about?

MediaWiki 1.20.2
PHP 5.3.3 (apache2handler)

(In reply to comment #6)

MediaWiki 1.20.2

Unrelated to this specific bug but I highly recommend upgrading to the latest 1.20.x.

Problem is reproducible with testcase in comment 4 on http://commons.wikimedia.beta.wmflabs.org/wiki/Special:UploadWizard

Message: "The upload succeeded, but the server could not get a preview thumbnail"

Same message in bug 48700 comment 3.

The file thumbnails correctly for me locally using Ghostscript 9.15.

matmarex changed the task status from Open to Stalled.Jul 20 2016, 3:23 PM

Problem is reproducible with testcase in comment 4 on http://commons.wikimedia.beta.wmflabs.org/wiki/Special:UploadWizard

Message: "The upload succeeded, but the server could not get a preview thumbnail"

Same message in bug 48700 comment 3.

I can no longer reproduce this on http://commons.wikimedia.beta.wmflabs.org/wiki/Special:UploadWizard or https://commons.wikimedia.org/wiki/Special:UploadWizard. The file thumbnail is shown correctly.

Closing as this cannot be reproduced anymore nowadays. Please reopen if you can still reproduce.