Page MenuHomePhabricator

MediaWiki silently breaks when you enable $wgValidateAllHtml outside of Apache
Closed, ResolvedPublic

Description

wfOutputHandler's $wgValidateAllHtml block uses apache_response_headers() which is not present in all SAPIs without checking if it exists. This leads to an error.

However because wfOutputHandler is an output handler printing output is not permitted and the error that's triggered gets swallowed up.


Version: 1.22.0
Severity: normal

Details

Reference
bz48342

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 1:27 AM
bzimport added a project: MediaWiki-General.
bzimport set Reference to bz48342.
  • Bug 48343 has been marked as a duplicate of this bug. ***
IAlex added a comment.May 14 2013, 1:39 PM

Patch in Gerrit changeset #63631.

IAlex: FYI, adding "bug: 48342" as the last line in your commit message will make the Gerrit bot automatically add a comment to the corresponding bug report, see http://www.mediawiki.org/wiki/Gerrit/Commit_message_guidelines

The patch was merged quite a while ago (as rMW559afbf6d3a92123), so is this bug now fixed?

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 19 2015, 12:50 AM
Aklapper closed this task as Resolved.Aug 20 2015, 3:51 PM

The patch was merged quite a while ago (as rMW559afbf6d3a92123), so is this bug now fixed?

No reply from @IAlex - assuming this is fixed. If not, please reopen.