Implement a find/search and replace tool
Closed, ResolvedPublic

Description

There's a search-and-replace tool in the wikiEditor which some users might miss and would like in VisualEditor somehow.


Version: unspecified
Severity: enhancement

bzimport set Reference to bz48368.
Jdforrester-WMF created this task.Via LegacyMay 12 2013, 1:17 AM
He7d3r added a comment.Via ConduitAug 8 2013, 1:21 PM

As long as it doesn't have the same performance issues which makes it unusable (bug 23510), I support this. :-)

Aklapper added a comment.Via ConduitAug 25 2013, 8:01 PM
  • Bug 53326 has been marked as a duplicate of this bug. ***
Whatamidoing-WMF added a comment.Via ConduitDec 8 2013, 2:13 AM

This still seems to be a popular request from users at multiple Wikipedias.

Amire80 added a comment.Via ConduitMar 27 2014, 12:59 PM

I'd say that it's a regression and not an enhancement.

Amire80 added a comment.Via ConduitApr 5 2014, 8:17 AM

Somebody told me that my comment was unclear: when I say that it's a regression and not an enhancement, I mean that the *lack* of search and replace functionality is a regression, and the request to have it should be treated as a bug report and not as an enhancement request.

eranroz added a comment.Via ConduitApr 5 2014, 8:40 AM

I agree with Amir. This is regression as this option is already available in WikiEditor and it is very basic functionality (available even in simple notepad), so it isn't an enhancement but at least normal (or major?) bug.

As part of the work on [[meta:Grants:IEG/Visual_editor-_gadgets_compatibility]], I plan to work on [[meta:User:Pathoschild/Scripts/Regex menu framework]], that should give a quick&dirty workaround to this issue.

He7d3r added a comment.Via ConduitApr 5 2014, 4:48 PM

(In reply to Eran Roz from comment #6)

As part of the work on
[[meta:Grants:IEG/Visual_editor-_gadgets_compatibility]], I plan to work on
[[meta:User:Pathoschild/Scripts/Regex menu framework]], that should give a
quick&dirty workaround to this issue.

Consider using the new version of that script instead:
[[m:User:Pathoschild/Scripts/TemplateScript]]

eranroz added a comment.Via ConduitMay 1 2014, 5:02 PM

We have a first working draft for replace tool for VE:
https://en.wikipedia.org/wiki/User:%D7%A2%D7%A8%D7%9F/veReplace.js

It works and replace the specified text, and undo&redo are properly supported (the last is just a claim that we didn't hack the VE too much :) ).
Currently it does only "replace all" but it can be easily extended with simple replace function, regexs and more...
We didn't "publish" it yet in village pumps since we want to do add at least some of this features before.

Jdforrester-WMF added a comment.Via ConduitMay 1 2014, 8:14 PM

(In reply to Eran Roz from comment #8)

We have a first working draft for replace tool for VE:
https://en.wikipedia.org/wiki/User:%D7%A2%D7%A8%D7%9F/veReplace.js

This ends up in the (mis-labelled) "Insert" menu, right? Would it be helpful it we created a category of tool to manipulate the contents (a spelling or grammar tool might also fit here, though again it's something you'd generally expect your browser to provide)?

eranroz added a comment.Via ConduitMay 23 2014, 9:13 PM

Yes, I would like if it would be possible to create an extra different menu, instead of adding all the tools to mislabelled "Insert". I think the new "Language" option will also fit here.

Jdforrester-WMF added a comment.Via ConduitMay 23 2014, 9:22 PM

(In reply to Eran Roz from comment #10)

Yes, I would like if it would be possible to create an extra different menu,
instead of adding all the tools to mislabelled "Insert". I think the new
"Language" option will also fit here.

Hmm. Possibly. I was thinking of putting it in the "text styling" menu, but it could live here.

Is there anything else that would live in the "Tools" menu? (Note that the obvious items to go in a "tools" menu – copy, cut, paste, paste formatting – can't be done in Javascript at all, sadly.)

eranroz added a comment.Via ConduitMay 23 2014, 9:38 PM

I can only think of "Language" and "Replace", so I guess we don't have enougth tools right now for a new menu.
(or maybe the "advanced" options (page settings, categories etc...) is actually "tools" menu?)

Jdforrester-WMF added a comment.Via ConduitMay 23 2014, 11:39 PM

(In reply to Eran Roz from comment #12)

I can only think of "Language" and "Replace", so I guess we don't have
enougth tools right now for a new menu.
(or maybe the "advanced" options (page settings, categories etc...) is
actually "tools" menu?)

We've been struggling with what to do with categories (which are pretty vital) compared to "don't show TOC" (which is pretty rare). Suggestions for improvements to the toolbar are always welcome. :-)

Esanders claimed this task.Via WebNov 24 2014, 12:12 AM
Esanders set Security to None.
Jdforrester-WMF moved this task to Doing on the VisualEditor workboard.
Esanders added a comment.Via WebNov 24 2014, 1:18 AM

For now I think the tool can go in the hamburger menu on the right.

Jdforrester-WMF added a subscriber: Esanders.Via WebNov 24 2014, 2:09 AM

For now I think the tool can go in the hamburger menu on the right.

What about in non-MW integrations?

Esanders added a comment.Via WebNov 24 2014, 10:28 AM

Same. See the commit above.

Jdforrester-WMF changed the title from "VisualEditor: Implement a find/search and replace tool" to "Implement a find/search and replace tool".Via WebNov 24 2014, 3:49 PM
Jdforrester-WMF moved this task to Done on the VisualEditor workboard.Via WebDec 3 2014, 6:21 PM
gerritbot added a comment.Via ConduitDec 3 2014, 6:24 PM

Change 174491 merged by jenkins-bot:
Find and replace

https://gerrit.wikimedia.org/r/174491

Jdforrester-WMF closed this task as "Resolved".Via WebDec 4 2014, 9:46 PM
RandomDSdevel awarded a token.Via WebDec 16 2014, 12:47 AM

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.