Page MenuHomePhabricator

VisualEditor: Paste of content does not use the context's annotation
Closed, ResolvedPublic0 Story Points

Description

If you have some text with an annotation (e.g. bold, italics or a link) and copy in some text, the annotation is closed off, the text is insert as plain text, and then the annotation is restarted.

I think users will expect "paste as current style" over "paste as plain text".


Version: unspecified
Severity: enhancement

Details

Reference
bz48720

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:24 AM
bzimport set Reference to bz48720.
  • Bug 48159 has been marked as a duplicate of this bug. ***

LibreOffice uses additive annotations, so pasting italic text into bold text results in bold+italic text. Google drive uses our current functionality.

An editor at the English Wikipedia comments that the ability to copy and paste a link is " definitely not an [sic] luxury feature but core functionality."

I am inclined to agree.

(In reply to comment #3)

An editor at the English Wikipedia comments that the ability to copy and
paste
a link is " definitely not an [sic] luxury feature but core functionality."
I am inclined to agree.

That's presumably meant for bug 33105 which is about copying and pasting rich content, rather than this one?

erm, yes. Sorry.

Normal paste (rich paste) should preserve the formatting of the pasted content (even if that means plain). Plain text paste should take the formatting of the target.

  • Bug 69653 has been marked as a duplicate of this bug. ***
Jdforrester-WMF lowered the priority of this task from High to Normal.Jan 15 2015, 12:20 AM

I definitely expect that text pasted into the middle of a link will still be part of the link. [[Link|Li]]HardToType[[Link|nk]] is never what I want, and if you end up with that, it's hard to repair (unlike a missing or extra bit of bold text). Since the T130735: Keyboard shortcut to paste plain text does nothing on Macs in Safari/Firefox in Safari, then "just (magically know about and remember to) use plain-paste" isn't a viable solution.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptMar 23 2016, 5:01 PM
Krinkle removed a subscriber: Krinkle.Mar 29 2016, 10:30 PM
matmarex closed this task as Resolved.Apr 5 2017, 4:12 PM
matmarex added a subscriber: matmarex.

This seems to work as expected these days. I just tried pasting various annotated things into various other things, and everything behaves fine, with the annotations being merged.

https://en.wikipedia.org/w/index.php?title=User:Matma_Rex/sandbox&diff=773983701&oldid=773982287

(Although in the meantime I discovered we're too good at this, merging some annotations that don't make sense, see T162278: It's possible to paste a reference inside a wikilink, messing up the wikitext syntax.)

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptApr 5 2017, 4:12 PM
Jdforrester-WMF set the point value for this task to 0.