Page MenuHomePhabricator

[INTERLANG] Clicking on the 'Apply Settings' does not close the ULS panel
Closed, ResolvedPublic

Description

Clicking on the 'Apply Settings' button in the Language Settings panel presently does not close the settings panel. This is a regression.

Expected behaviour: Clicking on an active 'Apply Settings' button after making any changes should apply the changes and close the panel.


Version: unspecified
Severity: major

Details

Reference
bz48898

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:37 AM
bzimport set Reference to bz48898.
Arrbee created this task.May 28 2013, 3:21 PM

The bug happens if the user presses the 'Apply Settings' button only after enabling or disabling the input methods using the enable/disable toggle button in the 'Input settings'.

Some clarifications related to this topic are added below:

  • In order to keep the behaviour consistent, when changes are produced, the apply settings button should become enabled. Changes should be persisted after the user clicks on it, and the dialog closed.
  • For changes that are previewed immediately (such as changing fonts), the changes take effect immediately and the cancel button is used to revert them. This behaviour is consistent with the previous one ("Apply settings" closes the dialog and changes are valid) but provides immediate feedback to the user. The "enable/disable input method tools" button should behave as a previewed change since some users would expect their effect to be immediate.

Related URL: https://gerrit.wikimedia.org/r/66380 (Gerrit Change I9f5444ffd57ddf46d197ebdb23a18c0c4600b196)

Related URL: https://gerrit.wikimedia.org/r/66391 (Gerrit Change I0c05a9a1be14c1036110f84c7a0080b98f93ee1d)