VisualEditor: IE9/10 incompatibilities with saving process
Closed, ResolvedPublic


grey text, no diff appears after Review and save

Seen in IE9 and below, works OK in FF and Chrome:

Make an edit with VE
Click Review and save

Page text is greyed out; no diff appears; Review and save button remains clickable; user cannot complete edit

Version: unspecified
Severity: normal


Cmcmahon created this task.Via LegacyJun 5 2013, 4:39 PM
Jdforrester-WMF added a comment.Via ConduitJun 6 2013, 3:58 PM

IE8 and below aren't supported at all (and you shouldn't ever manage to get to use VE with them); assigning.

Krinkle added a comment.Via ConduitJun 23 2013, 11:46 PM

I can consistently reproduce:

  • Saving the page results in an uncaught exception "Permissions denied" originating from ve.bind -> $.proxy -> line "proxy = function () { return fn.apply( .." Presumably this is caused by IE9 (undocumented?) non-standard security model that rejects certain interaction between functions originating from different http requests (regardless of the origin, e.g. in this case they're both from load.php on the local wiki, no CDN involved)
  • Generating a diff ("Review changes") has a silent failure, no notification is emitted that allows us to hide the spinner or display an error message.
gerritbot added a comment.Via ConduitJun 23 2013, 11:47 PM

Related URL: (Gerrit Change I2ee2e33c89cac58863c9911fc3ad250c72a46206)

Krinkle added a comment.Via ConduitJun 24 2013, 12:02 AM

IE10 exhibits the same behaviour.

Jdforrester-WMF added a comment.Via ConduitJun 24 2013, 1:31 AM

Relabelling; this is a blocker to IE9/10 use.

Jdforrester-WMF added a comment.Via ConduitJun 24 2013, 2:41 PM
  • Bug 50086 has been marked as a duplicate of this bug. ***
Elitre added a comment.Via ConduitAug 21 2013, 5:06 PM

An user reports:
<<I just got a Edit beta tab on The Adventure of the Reigate Squire, even though I'm in IE 10. What's weirder is that this is the only page where I've seen a VE tab. Also, I can't make any edits with it: I changed a few words in one sentence and added an edit summary, but the thing's just hanging there. I got a message of Warning: Your edit may have been corrupted – please review before saving. However, I've been unable to find anything corrupt, even though I reviewed everything that I'd done. Nothing of WP:EF came up, either. 2001:18E8:2:1020:202A:8DD6:6403:B77 (talk) 16:25, 21 August 2013 (UTC)

After several minutes of fruitless waiting, I gave up and reloaded the page. I then tried to add Category:Reigate and Banstead to the article (it's where the story is set), but after typing an edit summary of "Add category", I was forced to see that it's just been hanging there again. 2001:18E8:2:1020:202A:8DD6:6403:B77 (talk) 16:30, 21 August 2013 (UTC) >>

Is this due to some tests or deployment sanity checks? Thanks.

Elitre added a comment.Via ConduitAug 21 2013, 5:06 PM

*a user

zeljkofilipin removed a subscriber: zeljkofilipin.Via WebDec 3 2014, 8:45 AM

Add Comment