Page MenuHomePhabricator

[Story] record wikibase recent change entries attributed as non-anon
Closed, ResolvedPublic

Description

right now, we don't have a good way to tie external edits (e.g. from wikidata) to a user on the client.

With single user accounts on wmf, that could provide way.

If central auth is not available (e.g. on third-party wikis), then it would be good to have another identifier for rc_id for "external" users, like -1. Or figure out another way to better handle these so they do not show up as "anon".


Issue shown via RC Filters (from T162628: 'Wikidata edits' filter does not recognize registered wikidata users ):

  1. On wiki that has RC filters enabled, select 'Wikidata edits ' and 'Unregistered'
  2. The above filters selection shows wikidata registered users ; 'Wikidata edits' and 'Registered' will return no results.

The screenshot is from plwiki:

Details

Reference
bz49315

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 2:00 AM
bzimport set Reference to bz49315.
bzimport added a subscriber: Unknown Object (MLST).
aude created this task.Jun 7 2013, 5:48 PM
  • Bug 43192 has been marked as a duplicate of this bug. ***
  • Bug 45044 has been marked as a duplicate of this bug. ***
  • Bug 49740 has been marked as a duplicate of this bug. ***
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 8 2015, 9:15 PM
Jonas renamed this task from record wikibase recent change entries attributed as non-anon to [Story] record wikibase recent change entries attributed as non-anon.Nov 2 2015, 3:28 PM
Jonas updated the task description. (Show Details)
Jonas set Security to None.

I started work on T162628: 'Wikidata edits' filter does not recognize registered wikidata users earlier, and saw that matej_suchanek linked it to here this morning. I think this is actually a duplicate.

I'm going to keep working on this, but I'll ping in the #wikidata IRC to make sure people are aware and we can discuss if needed.

I think the suggestion here of using -1 if CentralAuth is not available (it can also be if particular edge case accounts are not linked for some reason) is better than 0 which I said at T162628: 'Wikidata edits' filter does not recognize registered wikidata users .

Change 349977 had a related patch set uploaded (by Mattflaschen):
[mediawiki/extensions/Wikibase@master] WIP: Transform user ID from repo to client in change prop

https://gerrit.wikimedia.org/r/349977

daniel moved this task from Proposed to Review on the Wikidata-Former-Sprint-Board board.
daniel added a subscriber: daniel.

Putting this into the sprint so it gets review from the team.

@aude can you help with manually testing Matt's patch? It's looking good, but it needs verification. You have central auth set up, right?

Change 349977 merged by jenkins-bot:
[mediawiki/extensions/Wikibase@master] Transform user ID from repo to client in change prop

https://gerrit.wikimedia.org/r/349977

hoo closed this task as Resolved.Aug 29 2017, 5:39 PM