Page MenuHomePhabricator

ULS triggers aren't shown in IE8 in Windows XP on Wikipedia and Wiktionary sites
Closed, DeclinedPublic

Description

OS: Windows XP
Browser: IE8
Tried sites: hi.wikipedia.org, bn.wikipedia.org, commons.wikimedia.org

The cog icon and the top ULS icon are not shown on this setup.

They are shown in IE8 on Windows 7, but not Windows XP.

(All the tests were done through crossbrowsertesting.com.)


Version: master
Severity: normal
OS: Windows XP
Platform: PC
See Also:
https://rt.wikimedia.org/Ticket/Display.html?id=5306
https://wikimedia.mingle.thoughtworks.com/projects/language_engineering/cards/3518

Details

Reference
bz49548

Event Timeline

bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz49548.
bzimport added a subscriber: Unknown Object (MLST).
Amire80 created this task.Jun 13 2013, 8:52 PM

Both anonymous and logged in. Tried purging, too.

Works on beta and translatewiki.net, so something special about WMF production is going on. Also loading of translations fails. No JavaScript errors shown.

(In reply to comment #2)

loading of translations fails. No JavaScript errors shown.

That's a separate issue. Should be reported and have a high priority. We wrote an API wrapper especially for this, so it not working is a major issue.

I'm considering this a blocker for ULS deployment phase 2. Should be resolved by Monday end of day, so it can be deployed (and backported) on Tuesday just before the configuration changes of gerrit 68146.

The bug happens only when IE8 is used with IE7 compatible mode. It works as expected when IE8 is used in IE8 mode.

It is also noticed that IE8 forces IE7 compatible mode for *.wikimedia.org sites, but could not find any documentation regarding this.

Confirmed that, it is Microsoft forcing *.wikipedia.org sites to degrade to IE7.
In IE8+Windows XP, tools->Compatibility view settings -> uncheck 'Inlcude updated website links from microsoft' option. That will reload the page in IE8 standards mode and everything will be working as expected.

With I9feb342b091e00ef0279333018b86045932d68de and I140352f723bc4863d14ed6441c9e173310c683b3, the current behavior is, if the browser is in IE7 compatible mode, ULS will not be enabled(ULS does not support IE7).

This is RT 5306.

So is this something that is still "highest priority"?

(In reply to comment #10)

So is this something that is still "highest priority"?

Yes. There has been other highest priority work before it, which is why it hasn't been addressed yet.

Decreasing priority.

Change 103387 had a related patch set uploaded by Siebrand:
Fix to avoid IE "compatibility view"

https://gerrit.wikimedia.org/r/103387

Change 103387 had a related patch set uploaded by Siebrand:
Fix to avoid IE "compatibility view"

https://gerrit.wikimedia.org/r/103387

Change 103387 merged by jenkins-bot:
Fix to avoid IE "compatibility view"

https://gerrit.wikimedia.org/r/103387

I'm going to tentatively mark this as resolved per the patch above. If the issue persists with the patch (which will be deployed on Wikipedias on Thursday, 30 January 2014), please reopen this bug and we'll investigate.

I doubt that it fixed the bug. ULS is now disabled but default, but it's probably not the issue. If I enable it in the preferences and try to use IE8 on Windows XP, I don't see the triggers. The ULS isBrowserSupported function returns false, even though we only blacklist IE 7 and earlier.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptFeb 14 2016, 5:28 PM
santhosh closed this task as Declined.Mar 30 2016, 6:23 AM

Since the OS and browser in this task is very old and no plans to support it, I am closing this. See https://www.mediawiki.org/wiki/Compatibility