Page MenuHomePhabricator

mediawiki.feedback fails badly when it can't write to the target page
Closed, ResolvedPublic

Description

Screenshot of the issue

  1. Go to http://www.mediawiki.org/wiki/MLEB
  2. Click edit section for Add/update your LocalSettings.php

Observed: Page scrolls up and some very different section is hihglighted. No editor chrome is shown. (Is there a bug for this?)

  1. Scroll down back to the section named above

Observed: Cannot edit the syntaxhighlighted block
Observed: Editor chrome appears

  1. Click beta on the toolbar
  2. Click leave feedback

Observed: page is dimmed and otherwise unfunctional and nothing can be done. See attached screenshot.


Version: 1.22.0
Severity: major
URL: http://www.mediawiki.org/wiki/MLEB

Attached:

Details

Reference
bz49636
Related Gerrit Patches:

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:54 AM
bzimport added a project: MediaWiki-JavaScript.
bzimport set Reference to bz49636.
bzimport added a subscriber: Unknown Object (MLST).

The proximate cause of this is that the (MediaWiki core!) feedback tool is pointed at a page that is protected, and it doesn't fail nicely.

More generally, the problem is that the target page is an LQT page, and LQT doesn't intercept section=new through the API, only through the skin interface, so these feedback items are mis-directed. See 41276.

I'm unprotecting the target LQT section header again, though this is not very much more helpful for all concerned. :-(

(In reply to comment #1)

The proximate cause of this is that the (MediaWiki core!) feedback tool is
pointed at a page that is protected, and it doesn't fail nicely.

You're sure that that is MediaWiki core. /me is unaware of any feedback tool in mediawiki core.

(In reply to comment #2)

(In reply to comment #1)

The proximate cause of this is that the (MediaWiki core!) feedback tool is
pointed at a page that is protected, and it doesn't fail nicely.

You're sure that that is MediaWiki core. /me is unaware of any feedback tool
in mediawiki core.

MediaWiki/core.git -> /resources/mediawiki/mediawiki.feedback.js:

https://git.wikimedia.org/blob/mediawiki%2Fcore.git/6a3bc6294a1b5b42a4d0f7062152d892e0aed1d3/resources%2Fmediawiki%2Fmediawiki.feedback.js

Always surprised how few people know about it, given how key it was for the Vector roll-out.

With precisely 0 uses in core :P

(In reply to comment #4)

With precisely 0 uses in core :P

That's Platform's call, not mine. :-)

(In reply to comment #3)

Always surprised how few people know about it, given how key it was for the
Vector roll-out.

For the records, https://meta.wikimedia.org/wiki/Vector#How_can_I_give_feedback_about_the_new_skin.3F I guess.
The feedback page(s) had a mere hundred edits? It's not surprising they weren't noticed http://vs.aka-online.de/cgi-bin/wppagehiststat.pl?lang=meta.wikimedia&page=2010+Wikimedia+design+and+feature+change%2FFeedback
(And I now see I even helped process the feedback there...)

ganeshaditya1 wrote:

Can't see the beta button no more.

(In reply to ganeshaditya1 from comment #7)

Can't see the beta button no more.

Yes, the 'beta' button that this referred to last June no longer exists, but you can still get to the feedback form inside VE from the 'help' menu.

Krinkle renamed this task from [mediawiki.feedback.js] MediaWiki's "feedback" tool fails badly when it can't write to the target page to mediawiki.feedback fails badly when it can't write to the target page.Nov 25 2014, 6:47 PM
Krinkle set Security to None.
Krinkle removed a subscriber: Unknown Object (MLST).
TheDJ added a subscriber: TheDJ.Dec 8 2014, 11:06 AM

Tested on test.wikipedia.org
It now properly adds a closable dialog with the error: "No response from API", probably this ticket was fixed due to some cleanup and refactoring to the promises api that we have been doing throughout core over the year.

I've made a few small improvements to the error handling, so that we at least have a log line reporting the error, but that's even outside the scope of this ticket to be honest.

Change 178178 had a related patch set uploaded (by TheDJ):
mediawiki.feedback: improve error handling

https://gerrit.wikimedia.org/r/178178

Patch-For-Review

Change 178178 merged by jenkins-bot:
mediawiki.feedback: Improve error handling

https://gerrit.wikimedia.org/r/178178

Jdforrester-WMF closed this task as Resolved.Dec 8 2014, 3:58 PM
Jdforrester-WMF claimed this task.

Tested on test.wikipedia.org
It now properly adds a closable dialog with the error: "No response from API", probably this ticket was fixed due to some cleanup and refactoring to the promises api that we have been doing throughout core over the year.
I've made a few small improvements to the error handling, so that we at least have a log line reporting the error, but that's even outside the scope of this ticket to be honest.

Marking as Resolved, then, given that even that supernumerary patch is now merged.

Krinkle removed a subscriber: Krinkle.Dec 10 2014, 3:08 PM