Page MenuHomePhabricator

Restore full text search/grepping on the whole repository
Closed, ResolvedPublic

Description

Gitweb had a grep feature, probably the only thing we miss of it.

Gitblit supports only lucene search, which doesn't seem to scale for our repository (but needs more testing, I hear). Also: "I have no interest in implementing a regex search because the Lucene search fits my needs. If you would like to contribute a regex search I'd be happy to merge it." https://code.google.com/p/gitblit/issues/detail?id=87

https://blog.mozilla.org/webdev/2013/06/13/dxr-digests-the-firefox-codebase/ made me curious about DXR but the docs are too intricate (https://github.com/mozilla/dxr/issues/139).


Version: unspecified
Severity: enhancement
URL: http://git.wikimedia.org/

Details

Reference
bz49674

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 1:56 AM
bzimport added a project: Gerrit.
bzimport set Reference to bz49674.
bzimport added a subscriber: Unknown Object (MLST).
Nemo_bis created this task.Jun 17 2013, 7:32 AM
  • This bug has been marked as a duplicate of bug 49229 ***

(In reply to comment #1)

  • This bug has been marked as a duplicate of bug 49229 ***

Doesn't look so to me, unless it's decided that Lucene is the only way of course.

  • Bug 49702 has been marked as a duplicate of this bug. ***
He7d3r added a comment.EditedJun 17 2013, 4:26 PM

Copying from T51702: Setup a web-based service to search across file contents:

After the migration to gitblit I miss the feature which allowed us to search
which files contain a given string, or match a given REGEX. I remmember I
linked to some of these searches on ptwiki. The links were like this:
https://gerrit.wikimedia.org/r/gitweb?p=mediawiki%2Fcore.git&a=search&h=HEAD&st=grep&s=EXAMPLE

Would it be possible to setup something equivalent for git.wikimedia.org?

PS: Before git, there was also this tool:
https://wiki.toolserver.org/view/Wikimedia_SVN_Search
http://toolserver.org/~krinkle/wikimedia-svn-search/
Maybe Krinkle would be able to port it to git?

(In reply to comment #4)

PS: Before git, there was also this tool:
https://wiki.toolserver.org/view/Wikimedia_SVN_Search
http://toolserver.org/~krinkle/wikimedia-svn-search/
Maybe Krinkle would be able to port it to git?

FYI, before the gitweb grepping worked, I started keeping a clone of core and extensions on Toolserver at /mnt/user-store/git, so that someone could made such a tool if wanted.

Krinkle removed a subscriber: Krinkle.Dec 3 2014, 12:35 AM
demon removed a subscriber: demon.Dec 8 2014, 6:33 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 11 2015, 4:05 PM
Nemo_bis closed this task as Resolved.Aug 27 2015, 7:11 AM
Nemo_bis claimed this task.

Well we can call this fixed now since all repositories are in Diffusion which supports grepping.