Window title for "Creating" should support parser functions
Closed, DeclinedPublic

Description

The browser window title is changed to "Parse error at position 0 in input {{"}}{{{1|$1}}}{{"}}" when editing an article with the VisualEditor on dewp. Reproducible in many articles and at least Firefox and Chromium.

bzimport added a project: VisualEditor-MediaWiki.Via ConduitNov 22 2014, 1:47 AM
bzimport set Reference to bz49951.
Lydia_Pintscher created this task.Via LegacyJun 21 2013, 9:21 AM
TTO added a comment.Via ConduitJun 21 2013, 11:12 AM

This seems to be caused by the templates in [[de:MediaWiki:Editing]].

Can be seen on testwiki as well, where parser functions are the cause ([[testwiki:MediaWiki:Editing]]).

Lydia_Pintscher added a comment.Via ConduitJun 29 2013, 6:28 PM

This seems solved now on dewp. Good to close from my side.

TTO added a comment.Via ConduitMar 1 2014, 12:32 AM

This is still an issue. I've restored MediaWiki:Editing on testwiki for demonstration purposes.

Krinkle has stated "Don't use wikitext in this message" (MediaWiki:Editing), but he didn't give a reason. Since parser functions, etc. work fine in this message in MediaWiki core, I think we should expect VE to handle them too, or else it should use a different message that specifically does not support fancy stuff.

Jdforrester-WMF moved this task to Backlog on the VisualEditor workboard.Via WebNov 24 2014, 4:22 PM
matmarex changed the title from "VisualEditor: Window title changed to "Parse error at position 0 in input {{"}}{{{1|$1}}}{{"}}" on some pages" to "Window title changed to "{{„}}{{{1|$1}}}{{“}} – Erstellen" when creating a new page".Via WebFri, Apr 10, 4:57 PM
matmarex set Security to None.
matmarex added a subscriber: matmarex.Via WebFri, Apr 10, 5:00 PM

This is still a problem, currently only visible when creating a new page because https://de.wikipedia.org/w/index.php?title=MediaWiki:Editing&action=edit no longer has the templates, but https://de.wikipedia.org/w/index.php?title=MediaWiki:Creating&action=edit still does. T95711 is the same bug for MediaWiki's live preview feature.

matmarex added a comment.Via WebFri, Apr 10, 5:04 PM

(No "Parse error at position 0" since T54479 was fixed.)

Krinkle changed the title from "Window title changed to "{{„}}{{{1|$1}}}{{“}} – Erstellen" when creating a new page" to "Window title for "Creating" should support parser functions".Via WebFri, Apr 10, 6:39 PM
Krinkle edited the task description. (Show Details)

This and T95711 are wontfix. These localisation messages should not use parser functions. This was never intentionally supported and whatever localisation needs exist in German that need this should be filed as a separate task against MediaWiki core to find a way to support that.

Complex parser functions will not be supported in this interface message.

matmarex closed this task as "Declined".Via WebMon, Apr 13, 9:33 PM
matmarex claimed this task.

(If they're wontfix, then let's decline them.)

matmarex reassigned this task from matmarex to Krinkle.Via WebMon, Apr 13, 9:34 PM

Add Comment

Column Prototype
This is a very early prototype of a persistent column. It is not expected to work yet, and leaving it open will activate other new features which will break things. Press "\" (backslash) on your keyboard to close it now.