Page MenuHomePhabricator

Reloading of page because of changing webfont and loss of data
Closed, DeclinedPublic

Description

When someone tries to change the webfont in the middle of editing using ULS the page reloads and the typed text gets lost. This has to be fixed.


Version: unspecified
Severity: normal
Whiteboard: aklapper-moreinfo
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=46040

Details

Reference
bz49962

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:48 AM
bzimport set Reference to bz49962.
bzimport added a subscriber: Unknown Object (MLST).

(In reply to comment #0)

When someone tries to change the webfont in the middle of editing using ULS
the page reloads and the typed text gets lost. This has to be fixed.

How to reproduce (How exactly do I change the webfont)? Exact steps welcome.
On which website does this happen?
Also see https://www.mediawiki.org/wiki/How_to_report_a_bug for general info.

(In reply to comment #1)

(In reply to comment #0)

When someone tries to change the webfont in the middle of editing using ULS
the page reloads and the typed text gets lost. This has to be fixed.

How to reproduce (How exactly do I change the webfont)? Exact steps welcome.
On which website does this happen?
Also see https://www.mediawiki.org/wiki/How_to_report_a_bug for general info.

Click on the gear >> Display >> Fonts >> Select the font/System font. The moment you change the web font it reloads the page and the typed wikicode gets vanished.

Can you give the details of wiki you experienced this?- ie URL. Also please let us know whether you were logged in or not. We need the OS+Browser version details too. Thanks.

(In reply to comment #3)

Can you give the details of wiki you experienced this?- ie URL. Also please
let
us know whether you were logged in or not. We need the OS+Browser version
details too. Thanks.

I was testing this on https://or.wikipedia.org/wiki/WP:MBBS5, i was logged in from a Mac OS X 10.7.5, Browser used: Firefox 21.0

I tested this on iOS/iPad, logged in, and I cannot reproduce it.

Steps to reproduce:

  1. Go to https://or.wikipedia.org/wiki/ଉଇକିପିଡ଼ିଆ:MBBS5
  2. click any edit button
  3. Update some text in the edit area. In my case I added "sdsdsd"
  4. Click gear icon to open ULS
  5. Click Display
  6. Click Fonts
  7. Select other content and/or UI fonts
  8. Confirm selection by clicking the button Apply settings
  9. Check the contents of the text area.

Expected:
I. sdsdsd still present in text area

Observed:
II. Same as expected, i.e. works for me.

Can you please indicate if this is the correct scenario? If so, we may have different behaviors in different browsers.

Could not reproduce for me too.
Can you help us in debugging? I guess it may be because you have some local scripts/gadgets conflicting with ULS code.

  1. Go to https://or.wikipedia.org/wiki/ଉଇକିପିଡ଼ିଆ:MBBS5?debug=1
  2. In firefox, press F12 once page is loaded, developer tools will open up, take console. In the console tab, press the Persist button, next to Clear.
  3. Do the font selection, as per your report the page reloads. If the console has any errors reported, please let us know.

If this is difficult to you, try to do font selection by logging out and let us know if you still see the issue.

Performed steps as in comment 5 on OSX/Firefox 21.0. I'm getting expected results. Closing as WORKSFORME. Please reopen if steps to reproduce or more information are known.

Created attachment 12634
I could not find the option you have mentioned. attaching the screenshot

Attached: