Page MenuHomePhabricator

[DO NOT USE] MediaWiki PHP 5.5 compatibility (tracking) [superseded by #NewPHP]
Closed, InvalidPublic

Description

Tracking bug for PHP 5.5. Instead of just having to search for the bloated newphp keyword.


Version: unspecified
Severity: major

Details

Reference
bz49975

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 1:49 AM
bzimport set Reference to bz49975.
bzimport added a subscriber: Unknown Object (MLST).

Why does this depend on duplicate bug 30092 - "MediaWiki PHP 5.4 compatibility (tracking)"? And why does it also depend on two PHP 5.5 issues?

Are you sure you didn't mean PHP 5.5 instead?

(In reply to comment #1)

Are you sure you didn't mean PHP 5.5 instead?

;) I did. Typo.

Or rather... I forgot to change the version number after I copied the title.

(In reply to comment #0)

Instead of just having to search for the bloated newphp keyword.

Six open "newphp" tickets are "bloated"? LOL.

(In reply to comment #3)

(In reply to comment #0)

Instead of just having to search for the bloated newphp keyword.

Six open "newphp" tickets are "bloated"? LOL.

;) You're the one who hands out a url not restricted to open bugs giving it 27 bugs:
https://bugzilla.wikimedia.org/buglist.cgi?keywords=newphp&list_id=210507

The PHP website contains upgrade notes in PHP 5.5 <a href="http://www.php.net/migration55">here</a> and the ones that affect compatibility is <a href="http://www.php.net/manual/en/migration55.incompatible.php">here</a>. Notable functions that have breaking changes in PHP 5.5 are pack() and unpack() functions.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 24 2016, 12:15 PM
Danny_B moved this task from Unsorted to PHP 5.5 on the [DO NOT USE] NewPHP board.May 9 2016, 12:14 AM
Paladox updated the task description. (Show Details)May 22 2016, 4:09 PM
Paladox added a subscriber: Paladox.