VisualEditor: IME shift+ function for adding diacritical marks in Arabic broken
Closed, ResolvedPublic8 Story Points

Description

From http://www.mediawiki.org/wiki/Thread:VisualEditor/Feedback/Problem_with_using_shift%2B

"Hi. I have been using the visual editor for a while on ar Wikipedia, it is very nice and smooth for fast edits. However, I am facing a very strange problem when I need to add some Arabic diacritics known as tashkil; when I press shift+diacritic button (like x, e, or z) the letter I pressed starts to repeat itself endlessly, and it can only be stopped by refreshing the page and wasting the work I have did. Any thoughts?"


Version: unspecified
Severity: major
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=50631

Details

Bumping priority, moving module, assigning, slight rewording; note that we can't fix things in the past (;-)), so setting to next week's deployment deadline.

Thanks James - first bug report.

(In reply to comment #2)

Thanks James - first bug report.

No worries. :-) Welcome to the party.

dchan added a comment.Aug 19 2013, 6:19 PM

I think this may be resolved by the following patch:
https://gerrit.wikimedia.org/r/#/c/79451 . It fixes similar bugs in other scripts with similar properties.

If it's still broken, is it possible to give a specific example of:

  1. A piece of Arabic text where VisualEditor fails
  2. The keystrokes required to enter the text
  3. The incorrect output observed in VisualEditor
  4. The OS, browser and input method used.

Thanks!

Change 80080 had a related patch set uploaded by Jforrester:
WIP:Don't emit Surface changes back to the Surface

https://gerrit.wikimedia.org/r/80080

aaddira wrote:

Thank you. I have tested all possible diacritics on Arabic Wikipedia and everything is working great. Good job!

Change 80080 merged by jenkins-bot:
Don't emit Surface changes back to the Surface

https://gerrit.wikimedia.org/r/80080

Given that this is now merged, I'm going to mark this as fixed. However, this is provisional - please re-open if you think that this has not worked!

Jdforrester-WMF set Security to None.
Jdforrester-WMF edited a custom field.

Add Comment