VisualEditor: Can't copy/paste header from start of document without losing formatting
Closed, ResolvedPublic0 Story Points

Description

See https://en.wikipedia.org/w/index.php?title=User:JohnCD/VEtest&diff=prev&oldid=561397375 - the header is de-headered, and a spurious nowiki tag added.


Version: unspecified
Severity: normal

Details

Reference
bz50126
bzimport raised the priority of this task from to High.
bzimport set Reference to bz50126.

Can't reproduce the last heading nowiki-ing, but the first of a document appears to be unable to copy with formatting.

  • Bug 54728 has been marked as a duplicate of this bug. ***
Jdforrester-WMF lowered the priority of this task from High to Normal.Jan 9 2015, 10:55 PM
Elitre added a subscriber: Elitre.Sep 23 2015, 2:50 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptSep 23 2015, 2:50 PM

It doesn't really matter if the header is the first one, and also happens when the entire section is selected.

See https://en.wikipedia.org/w/index.php?title=User:JohnCD/VEtest&diff=prev&oldid=561397375 - the header is de-headered, and a spurious nowiki tag added.

This link is dead, it seems the page was deleted.

Restricted Application added a subscriber: jeblad. · View Herald TranscriptMar 23 2018, 9:57 PM

I can't reproduce this. I'm not sure what the original issue was, given the missing reproduction page, but a heading at the beginning doesn't seem to behave in any way differently than other headings.

To copy a heading along with the formatting, you have to select it together with the closing tag, which is a bit awkward and not obvious, but it's the same for all headings.

Krinkle removed a subscriber: Krinkle.Mar 24 2018, 1:58 AM
Krinkle closed this task as Resolved.Mar 24 2018, 2:09 AM
Krinkle claimed this task.

I peeked at the revision:

Before
==L2 Header==
===L3 header===
Some text including '''bold '''and ''italic ''and '''''both '''''at once
[..]
==Fourth L2 header==
After saving
==L2 Header==
===L3 header===
Some text including '''bold '''and ''italic ''and '''''both '''''at once
[..]
==Fourth L2 header==
L2 Header
===L3 header===
Some text including '''bold '''and ''italic ''and '''''both ''at once
===Another L3 header===
This line includes a [[Wikipedia:Wikilinks|wikilink]] as a sample
==<nowiki/>==

I presume the edit was to select from start ("L2 Header") until end of first sentence, copy that, and paste at the end. Nothing the bugs: 1) L2 Header didn't become a heading, and 2) odd <nowiki/> in a heading at the end. I could not reproduce this on testwiki today. Closing as resolved.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptMar 24 2018, 2:09 AM
Deskana set the point value for this task to 0.Mar 26 2018, 2:43 PM