Multiline comment followed by a space leads to the space being nowiki-escaped
Closed, ResolvedPublic

Description added matching nowiki tags, but the change didn't actually include any markup - or, well, anything (it was an attempt to add a comma, which hasn't appeared).

Version: unspecified
Severity: normal

bzimport added a project: Parsoid-Serializer.Via ConduitNov 22 2014, 1:44 AM
bzimport set Reference to bz50758.
Ironholds created this task.Via LegacyJul 4 2013, 4:54 PM
Ironholds added a comment.Via ConduitJul 4 2013, 5:12 PM

Belay that; comma appears, I'm just blind :). Still no reason for the nowikis I can see.

Mdennis-WMF added a comment.Via ConduitJul 4 2013, 7:06 PM

Original problem occurred on Firefox on Windows 7. I didn't replicate it, but another editor did with Chrome on Windows 7:

Jdforrester-WMF added a comment.Via ConduitJul 12 2013, 2:25 PM

This is reproducible; if you edit the original in VE and make no changes it clean-diffs (selser to the rescue), but if you try to replicate the edit (add a comma anywhere in the paragraph after the "Economics" heading), the text following the multi-line HTML comment is escaped in <nowiki>s.

ssastry added a comment.Via ConduitJul 12 2013, 2:38 PM

Simplified test case. Run this through wt2wt in Parsoid. " bar" will be nowiki escaped, but " foo" will not be.

--> foo

x <!--
--> bar

If you parse the above wikitext (ex: paste it in enwiki sandbox) " foo" will be rendered as preformatted text but " bar" is not. Parsoid handles that correctly.

But, the multiline comment followed by a space trips Parsoid's nowiki insertion code when converting the html to wikitext. It doesn't realize that " bar" will not be preformatted because the the comment did not start at the beginning of the line many lines up.

We'll look into this, but I suppose this is not a very common occurrence.

ssastry added a comment.Via ConduitJul 30 2013, 3:57 PM
  • Bug 52266 has been marked as a duplicate of this bug. ***
Arlolra placed this task up for grabs.Via WebNov 25 2014, 7:10 PM
Arlolra added a project: Parsoid.
Arlolra set Security to None.
Arlolra removed a subscriber: MarkTraceur.
Ironholds removed a subscriber: Ironholds.Via WebDec 5 2014, 7:45 PM
ssastry moved this task to html2wt: nowikis on the Parsoid workboard.Via WebDec 20 2014, 5:12 PM
RobLa-WMF added a project: Parsoid-Nowiki.Via WebFeb 11 2015, 8:10 PM
marcoil moved this task to Backlog on the Parsoid workboard.Via WebFeb 13 2015, 12:47 PM
Arlolra closed this task as "Resolved".Via WebAug 19 2015, 9:56 PM
Arlolra claimed this task.
Arlolra added a subscriber: Arlolra.

Parsoid handles the simplified test case above these days.

λ (master) cat t
--> foo

x <!--
--> bar

λ (master) cat t | node parse --wt2wt
--> foo

x <!--
--> bar

Add Comment