Page MenuHomePhabricator

Add a way to thank page patrollers for reviewing a page I created
Open, LowPublic

Description

There should be a way of thanking NPP patrollers for reviewing my creations. I think this would improve moral of reviewers and encourage more reviewers since I am sure there is always a backlog.


See Also:
T58155: Add thanks links to Special:NewPages

Details

Reference
bz50867

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 1:52 AM
bzimport added a project: Thanks.
bzimport set Reference to bz50867.
bzimport added a subscriber: Unknown Object (MLST).

So a more generic "thank for log entries"?

I was thinking a simple link in the notification for the review.

(In reply to comment #2)

I was thinking a simple link in the notification for the review.

Are there log entries for such reviews? Or can we just use patrol/patrol?

The 'patrol' action doesnt always mean the page patroller has accepted the created page. They may have tagged it for deletion and then marked it as patrolled to remove it from the patrol queue.

As a result the page creator needs to see what actions have been taken before they thank the page patroller, otherwise they will be thanking the patroller for deleting the page, which is not what they wanted to do.

One approach is to wait until echo understands negative feedback, like prod, csd and afd.

https://www.mediawiki.org/wiki/Echo_%28Notifications%29/Feature_requirements#Started_Page_-_Tagged

https://www.mediawiki.org/wiki/Echo_%28Notifications%29/Feature_requirements#Started_Page_-_Marked_for_deletion

The simplest solution is to take the creator to the history tab, where the reader can see the current status, and the 'thanks' buttons are ready to use.

I've mentioned that here:

https://www.mediawiki.org/wiki/Talk:Echo_%28Notifications%29/Testing#Links_in_notification_text

Another idea is to have a streamlined UI for the article creator to give a specific 'thanks for reviewing my page' WikiLove to a page patroller.

(In reply to comment #4)

The 'patrol' action doesnt always mean the page patroller has accepted the
created page. They may have tagged it for deletion and then marked it as
patrolled to remove it from the patrol queue.
As a result the page creator needs to see what actions have been taken before
they thank the page patroller, otherwise they will be thanking the patroller
for deleting the page, which is not what they wanted to do.

Why not? Some feedback is better than no feedback; we're supposed to be here for a shared goal, if the patrolling action was correct everyone should be happy. We also see people thanking for reverts of their own edits, as far as I know.

More in general, I suppose the assumption of the thanks feature is that people are able to discern and have enough context to judge the actions they click "thank" for; if not, why would this feature even exist?

The simplest solution is to take the creator to the history tab, where the
reader can see the current status, and the 'thanks' buttons are ready to use.

So your proposal to give users more context is appropriate, but it's a separate enhancement request (doesn't block not is blocked by this one).

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 28 2015, 1:39 AM
Restricted Application added a project: Growth-Team. · View Herald TranscriptOct 1 2019, 7:44 PM
matmarex closed this task as Resolved.Oct 2 2019, 3:10 PM

https://en.wikipedia.org/wiki/Special:Log/patrol has "thanks" links, so I assume this is resolved now. However, this might have been unintentional – see my comment on the other task: T60485#5541285.

Krinkle reopened this task as Open.Oct 3 2019, 4:50 AM
Krinkle added a subscriber: Krinkle.

I don't think this should be enabled for RC patrol, in particular because unlike NPP (which is at least sometimes used as endorsement/approval), RC patrol is never meant as endorsement. For RC patrol, marking as patrolled is the equivalent of deleting or archiving an e-mail, it signifies that the revision has been dealt with. Whether it was good, bad, needed a copy edit, or was reverted for vandalism all result in the same outcome.

Inviting use of Thanks here I believe was unintended. From a user perspective, it feels like yet another thing to worry about in the already complex and not-well-catered landscape of RC patrol workflows.

I've confirmed on commonswiki and nlwiki that the functionality has been enabled for RC patrol entries as well, which should probably be avoided. These can be distinguished with the log param previd which will be set to non-zero for RC patrol.

matej_suchanek removed a subscriber: wikibugs-l-list.