VisualEditor: Provide some way of opening external links within templates
Closed, ResolvedPublic0 Story Points

Description

From an editor on English Wikipedia:

On the whole, I really like it. It's basically intuitive and seems to have massively improved since I first tested it out. The main problem I'm having involves the amount of effort now required to open external links in references (especially those using {{cite web}} etc). As far as I can tell, I have to click on the footnote, then the icon, then the text of the reference, then another icon, then the url parameter, and once I'm done copy and pasting I have to close two pop-ups. Is there any way around this that I've missed? It's not an error or a bug, but it's the main barrier to efficient editing that I've encountered so far. – Arms & Hearts (talk) 16:03, 7 July 2013 (UTC)


Version: unspecified
Severity: enhancement

Details

Reference
bz50966
bzimport raised the priority of this task from to Normal.
bzimport set Reference to bz50966.

This affects more than just templates. You can't click to open any internal or external link that is located inside any "node" (galleries, image captions, <references />).

  • Bug 66549 has been marked as a duplicate of this bug. ***
Neil_P._Quinn_WMF closed this task as Resolved.Jul 25 2015, 12:09 AM
Neil_P._Quinn_WMF claimed this task.

It's now possible to easily open links in citations and image captions using the link inspector. The same isn't true of gallery captions, but that's because we still need to make a visual editor for galleries (T45037).

Jdforrester-WMF edited a custom field.