Page MenuHomePhabricator

Disable ULS by default on all ml wiki projects.
Closed, DeclinedPublic

Details

Reference
bz51019

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 2:02 AM
bzimport set Reference to bz51019.
bzimport added a subscriber: Unknown Object (MLST).
bzimport created this task.Jul 9 2013, 9:11 AM

Change 72702 had a related patch set uploaded by Nikerabbit:
Disable ULS on ml.*

https://gerrit.wikimedia.org/r/72702

Being deployed now.

Change 72702 merged by jenkins-bot:
Disable ULS on ml.*

https://gerrit.wikimedia.org/r/72702

kirangopi84 wrote:

We requested disable ULS by default, not remove the ULS

kirangopi84 wrote:

Reopening, as our request was not remove the ULS permannently, just disable the ULS by default.

kirangopi84 wrote:

The wrong fix persuade more problems, please correct it.

kirangopi84 wrote:

Changing the Importance and criticality as the provided fix is wrong.

the community requested only to disable the ULS by default, but the fix given as removed the ULS. Please correct the fix.

viswaprabha wrote:

As I understand, either we are all playing hide and seek or there is some grave errors in understanding among the stakeholders!

We *DID NOT* ask to COMPLETELY disable ULS from any projects.

For once again let me make it clear:

What we had requested was:

1.To have the ULS disabled as (initially) DEFAULT for all Malayalam Wikimedia projects. (Bug#51019)

2.To keep this option (to be able to switch the ULS OFF or oN) as an option within the user preference set. (Bug#46306)

  1. To have no particular web fonts set as INITIAL default for all Malayalam Language users who have not particularly opted for that. (Bug#49894)

The above bugs have never meant or asked to disable ULS/IME/WEBFONTS completely for all users. For particular situations and users the ULS and its associated features were expected to be remaining as a configurable option within the user's preferences.

I humbly request you all to go through the clearly translated matter of the original proposals at the community's page linked elsewhere above.

Now that the third possibility has also been removed blatantly, our ability to use the Narayam IME (which was well functioning hitherto) should be re-instated, as a minimum agreeable scenario.

Solving several different bugs by shutting down a single Master circuit breaker is not what we have asked for, through several different bugs! It only makes our community members feel punished!

tomasz added a comment.Jul 9 2013, 3:52 PM

Can't stand the rudeness in this and other Malayalam–related bugs, therefore un-CC'ing myself.

Just to give some context, the fix for bug 49894 had been enabled on the wikis 20 minutes before this bug was filed.

See http://www.mediawiki.org/wiki/Bugzilla/Fields for the meaning of the priority/severity fields. This is neither "immediate" nor "blocker". Thanks.

vinayarajweare wrote:

Sorry that you find rudeness in this. Everybody was typing Malayalam perfectly without any complaints for a long time. Then suddenly came ULS taking the not-so-technically-savvy people completely off the road. Bugs are filed to disable ULS in mlwikis "by default" and it is disabled completely. Now there are no way to input Malayalam. When we asked to enable Narayam at least temporarily till ULS problems are solved (Bug 51021 - Enable Narayam Extension in all ml wikimedia wikis ), it is marked as "Status: RESOLVED WONTFIX " These are very serious issues we face. Please don't take it lightly or as rude.

kirangopi84 wrote:

(In reply to comment #11)

See http://www.mediawiki.org/wiki/Bugzilla/Fields for the meaning of the
priority/severity fields. This is neither "immediate" nor "blocker". Thanks.

Andre:Please understand the situation here, dev team provided a wrong fix and we are not able to type malayalam in our wikis. From our perspective it is real blocker issue. Requesting you to either fix the issue or change the priority.

(In reply to comment #9)

Can't stand the rudeness in this and other Malayalam–related bugs....

Yes, all these things are also unbearable to poor editors who have no knowledge about other writing tools than inbuilt tools in wiki! It is marvellous, proceed dear brothers and cite this as a so called "wiki culture" !

  • In general on commenting here: **

I know the situation might be frustrating, but please don't add comments in Bugzilla that don't provide any additional insight. Comments create bugmail for everybody (which needs to get read) and make the conversation harder to read.
This is not a wikipage or forum but a technical bugtracker, so please feel free to make such comments in private emails or wikipages/forums instead. Thanks for your understanding.

(In reply to comment #13)

Andre:Please understand the situation here, dev team provided a wrong fix and
we are not able to type malayalam in our wikis.

The community's request was to disable ULS completely by default.
As http://www.mediawiki.org/wiki/Universal_Language_Selector/FAQ#How_can_I_disable_Universal_Language_Selector explains,
"Only part of the functionality can be disabled. Input methods can be completely disabled by clicking the keyboard icon and clicking Disable input tools. Web fonts can only be disabled per language in the settings."
(This part of the FAQ was already linked in the similar bug 46306 comment 17.)

Hence there is no UI to enable or disable ULS completely and "by default".
Hence for completely disabling ULS (as requested in this bug report), removing ULS was required in order to fulfil the request by the ml community. I assume that the developers acted in good faith, fulfilling the requests of the community.

If I get the last comments correctly, I assume that input methods for Malayalam are wanted again. Input methods are available via ULS.
I don't know which conclusions the Malayalam community would like to draw out of this, but you are free to discuss this on
https://ml.wikipedia.org/wiki/വിക്കിപീഡിയ:പഞ്ചായത്ത്_(സാങ്കേതികം) first.

To me it is currently unclear what is now asked for in this reopened bug report, as the community's request was fulfilled (though in a surprising way).

Somebody needs to clarify this and the community needs to speak with one voice here (after finding agreement, for example on വിക്കിപീഡിയ:പഞ്ചായത്ത്_(സാങ്കേതികം)), clearly keeping in mind the technical constraints explained above.

Currently this bug report is not actionable.
I can imagine that both the ml community and any developers are highly interested in avoiding more misunderstandings.

Some general information to potentially speed up the process of getting any kind of server configuration changes deployed: If anybody would like to create some software patch to change some server configuration again, please see

The files to change for this request are https://git.wikimedia.org/blob/operations%2Fmediawiki-config.git/HEAD/wmf-config%2FInitialiseSettings.php and linked to from comment 3. Please note that providing help with Git/Gerrit is out of scope for this specific bug report.

Thank you Andre Klapper for your concern and patience... The only thing our community arrived in a consensus that "we need ULS by optional not default. If a user wants to use inbuilt writing tool, then he/she can enable ULS for that purpose. Provided developers should look into other reported bugs and make it foolproof."

I think this is what Kiran tried to explain in his first comment. Unfortunately the same is taken in a negative sense!

Can we please get some clarity on what aspects of ULS are causing issues? If it's just the webfonts, let's set those to the system font for all Malayalam wikis and reinstate ULS itself.

Is the input method engine causing any actual issues? That's the only other part that could be disabled by default (as it is on enwiki). But if it's not causing issues and this is mostly about fonts (which is what I gathered from the English language comment on ml.wikipedia.org), then let's just set ULS to system font by default.

Regarding web fonts:
Ml wiki users need to have system font by default

Regarding Input:
We feel many bugs in ULS IME. So we request to put the ULS as on optional add-in at present for testing. At the same time, previous Narayam IME may be reenabled by default.

vssun: What are the bugs in ULS IME you're referring to? Are these in Bugzilla?

Vssun added a comment.Jul 10 2013, 1:31 AM

I am just translating the problems shared by users regarding ULS IME on our discussion page

  1. It is not as friendly as the earlier Narayam. There is a "To write in Malayalam" label was present in Narayam. Now users especially new users dont know how to enable that.
  2. There was clear colour-indication in Narayam that whether IME is enabled or not. In ULS, we need to start typing to determine it. a. Appearance and dissappearance of keyboard icon distracts users while typing
  3. Loading and response time for ULS IME is long.
  1. Bug 50790
  1. Pressing ctrl+z for undo in Edit boxes creates unwanted results

Some problems raised by users have been fixed (for eg. bug 49515, bug 49679)

Dear vssun,

I understand that you feel that improvements still need to be made to the ULS IME, and that's fair. The language engineering team will surely continue to improve them. The most critical issue of the ones you mention seems to be the one related to preferences, which already has a patch in progress.

Please help us make sure that all the issues above are tracked so we have clean steps to reproduce and assess them. Please remember that we have to support many different browsers and operating systems and it can take a while to iron out the kinks in all combinations.

However, restoring Narayam is not an option -- we're not going to maintain it any longer. In fact it's already been removed from the supported extensions on the cluster. While the ULS IME will surely benefit from further improvement, we depend on continued feedback from the community to prioritize improvements.

So we could potentially disable the input methods by default, but based on the severity of the bugs you're describing I would suggest starting by

  • re-enabling ULS
  • setting the default font for Malayalam to system font
  • re-enabling input methods and working through remaining issues in coming days.

Note that enabling input methods still means you only actually see them if you select an input method other than "native keyboard".

Erik

viswaprabha wrote:

Dear Eric,

Thank you for your latest comment and the compassionate and receptive response.

Personally myself (and possibly many among us) feel that this could be the way to go, as it will remove the impasse we have all come to. While many of the community members may still have various technical hitches to deal with the ULS interface, I am sure we can all work together and get rid of such issues in the forthcoming days. Certainly, our community never wanted to go astray or rebel away from the main stream goals and visions of Wikimedia ventures.

We shall discuss on the above suggestions within our community and come back in due time with an amicable and collective feedback. Until then, I request everyone to restrain from further discussions or changing bug status etc.

Thank you all!

Vssun added a comment.Jul 10 2013, 7:39 AM

(In reply to comment #22)

Dear vssun,
I understand that you feel that improvements still need to be made to the ULS
IME, and that's fair. The language engineering team will surely continue to
improve them. The most critical issue of the ones you mention seems to be the
one related to preferences, which already has a patch in progress.
Please help us make sure that all the issues above are tracked so we have
clean
steps to reproduce and assess them. Please remember that we have to support
many different browsers and operating systems and it can take a while to iron
out the kinks in all combinations.
However, restoring Narayam is not an option -- we're not going to maintain it
any longer. In fact it's already been removed from the supported extensions
on
the cluster. While the ULS IME will surely benefit from further improvement,
we
depend on continued feedback from the community to prioritize improvements.
So we could potentially disable the input methods by default, but based on
the
severity of the bugs you're describing I would suggest starting by

  • re-enabling ULS
  • setting the default font for Malayalam to system font
  • re-enabling input methods and working through remaining issues in coming

days.
Note that enabling input methods still means you only actually see them if
you
select an input method other than "native keyboard".
Erik

I personally agree with your suggestion.

(In reply to comment #21 by vssun)

I am just translating the problems shared by users regarding ULS IME on our
discussion page

This list is very helpful so developers can try to fix those issues and improve the user experience. Could you make sure that good bug reports (steps to reproduce, explaining the expected outcome and the current/actual outcome, and if possible adding screenshots) with one problem per report are created? This would help developers to keep an overview.
Also see https://www.mediawiki.org/wiki/How_to_report_a_bug

(In reply to comment #22 by Erik)

However, restoring Narayam is not an option -- we're not going to maintain it
any longer.

For the records (not to spark new discussion), this was covered in bug 51021.

  • re-enabling ULS
  • setting the default font for Malayalam to system font

For the records (not to spark new discussion), disabling the default web font for ml and serving a system font instead was done in bug 49894 / https://gerrit.wikimedia.org/r/#/c/72690/ but reverted in https://gerrit.wikimedia.org/r/#/c/72701/ due to this bug 51019.

  • re-enabling input methods and working through remaining issues in coming

days.

Vssun added a comment.Jul 11 2013, 9:28 AM

Dear Erik,

Note that enabling input methods still means you only actually see them if
you
select an input method other than "native keyboard".
Erik

By this, can I assume that ULS IME will be available at ml.wiki* but it will be enabled only after user select it from ULS preferences (as in English wikipedia at present)?

viswaprabha wrote:

Dear Erik & others,

The following is a possible configuration set, that I thought, should settle the issues for the users in Malayalam (ml) community for the time being. In order to avoid variance in opinions or interpretations, I had collected a rough and quick-opinion harvest at the community page. Many have expressed consensus to these suggestions:
(Please refer to: http://ml.wikipedia.org/wiki/Wiki_Panchayath_Technical#Explanatory_English_translation)

According to this,

  1. ULS may be incorporated in all ml.*.org projects in all scenarios and states.
  2. All those users who have logged in, will be provided with options to choose which IME (including system default i.e. native keyboard) should be set permanently within their own preferences settings.

#All users who have not logged in and those who have logged in but not explicitly opted for an alternate IME method in their user preferences, will have the IME option set to native keyboard (i.e. system IME) as default. The same will be ensured in all *.wiki.* projects as far as Malayalam interface is concerned.

  1. As Wikimedia developers have software compliance issues in continuing support to Narayam IME, WMF shall not provide Narayam as part of Wikimedia pages (either as built-in or as an extension). However, users or community may develop/adapt/implement their own IME methods by way of their user scripts or tools external to Wikipedia interface, under their own responsibility.
  2. The system fonts will be the default available font initially for Malayalam language in all *.wik*.org projects (as one opens a Wikimedia project page). However, besides this, there shall be a setting to choose a preferred Web font as permanent within the user preferences settings. The list of such webfonts will be maintained, expanded and updated as more of them get released/improved.
  3. In all ml.wik*.org projects, logged-in users will be able to set their chosen webfonts for each additional languages independently.
  4. There are pending technical issues faced by various users in various scenarios. The community will try to identify each one distinctly and report them as distinct bugs to developers on an ongoing basis. The community and developers will collectively and creatively try to get rid of all such technical issues.
  5. Any discussions regarding bugs will be focused on the very bug itself. The developers and community members will always restrain themselves to be within a symbiotic discussion environment with the sole goal of fixing the bug and carrying the vision and mission of Wikimedia ventures forward.

(In reply to comment #27)

tldr: ULS will be re-enabled on all ml wikis, and the default web font for "ml" will be system. These changes will be made immediately (and will have been made by the time you read this).

  1. ULS may be incorporated in all ml.*.org projects in all scenarios and

states.

This is a permission to re-enable ULS on all ml wikis if we would want that. We will. https://gerrit.wikimedia.org/r/#/c/72702/ will be reverted about now.

  1. All those users who have logged in, will be provided with options to choose

which IME (including system default i.e. native keyboard) should be set
permanently within their own preferences settings.

This is a standard setting for all Wikimedia wikis. No problem.

  1. All users who have not logged in and those who have logged in but not

explicitly opted for an alternate IME method in their user preferences, will
have the IME option set to native keyboard (i.e. system IME) as default. The
same will be ensured in all *.wiki.* projects as far as Malayalam interface
is concerned.

This is a standard setting for all Wikimedia wikis. Input methods are enabled (the keyboard icon appears on input fields) and no input method is active (i.e. the input is unaltered). No problem.

  1. As Wikimedia developers have software compliance issues in continuing support

to Narayam IME, WMF shall not provide Narayam as part of Wikimedia pages
(either as built-in or as an extension). However, users or community may
develop/adapt/implement their own IME methods by way of their user scripts or
tools external to Wikipedia interface, under their own responsibility.

Communities have free reign over their JavaScript and CSS pages. We strongly advise against software development for all users of a specific Wikimedia wiki without co-ordinating with Wikimedia Foundation developers. WMF can provide continuity that a community in some cases cannot provide.

5a. The system fonts will be the default available font initially for Malayalam
language in all *.wik*.org projects (as one opens a Wikimedia project page).

Currently ULS has a default web font configured for the language code "ml". https://gerrit.wikimedia.org/r/#/c/72690/ will be re-applied for this request to be fulfilled. This is done about now, and will be made available within the next few tens of minutes to all wikis of Wikimedia.

5b. However, besides this, there shall be a setting to choose a preferred web font
as permanent within the user preferences settings. The list of such webfonts
will be maintained, expanded and updated as more of them get
released/improved.

We are not absolutely certain if we understand this request. With the current understanding, we think there is no change in ULS functionality needed.

  1. In all ml.wik*.org projects, logged-in users will be able to set their chosen

webfonts for each additional languages independently.

We are not absolutely certain if we understand this request. With the current understanding, we think there is no change in ULS functionality needed.

  1. There are pending technical issues faced by various users in various

scenarios. The community will try to identify each one distinctly and report
them as distinct bugs to developers on an ongoing basis. The community and
developers will collectively and creatively try to get rid of all such
technical issues.

Yes, please. Do be aware that we currently have not planned to make short term investments in feature development in ULS. We will address high priority problems, but most likely not feature requests.

  1. Any discussions regarding bugs will be focused on the very bug itself. The

developers and community members will always restrain themselves to be wthin
a symbiotic discussion environment with the sole goal of fixing the bug and
carrying the vision and mission of Wikimedia ventures forward.

Aside from the hard to achieve always, this seems extremely efficient and will prove to be very effective, I'm sure. This is an issue tracker, and as such we should try to keep issues distinct, precise and clear.

Change 73932 had a related patch set uploaded by Siebrand:
Disable default web font for language code "ml" again.

https://gerrit.wikimedia.org/r/73932

Change 73934 had a related patch set uploaded by Siebrand:
Revert "Disable ULS on ml.*"

https://gerrit.wikimedia.org/r/73934

Change 73932 merged by jenkins-bot:
Disable default web font for language code "ml" again.

https://gerrit.wikimedia.org/r/73932

Change 73934 merged by jenkins-bot:
Revert "Disable ULS on ml.*"

https://gerrit.wikimedia.org/r/73934

viswaprabha wrote:

Dear all,

We, at Malayalam Wikimedia projects, are extremely happy to see that the development and resolution of this bug has reinforced our belief in our unity as well as in the great march that Wikimedia has been pursuing.

Almost all of the modifications we have suggested and wanted (for matters of technical integrity, user interface experience and individual freedom of choice) are now incorporated into the ULS as far as Malayalam language is concerned. More than 24 hours has passed. No one seems to have raised any new or persisting problems after the new changes.

Most of the veteran editors and proponents of Malayalam Wikipedia have come back to their regular activities.

Thank you all for the kindness and understanding that was put forth during this rather inconvenient period.

I think now we can close this (and most related bugs) as RESOLVED.

Certainly, we will come back with bugs and feature requests as and when we feel there is a legible need.

Thank you!

Extremely happy to hear that, and glad that everybody together found a way to work out most issues. Thanks for everybody's patience, too.

I think now we can close this (and most related bugs) as RESOLVED.

Happily doing so. :)