Page MenuHomePhabricator

remove disambiguation pages from Special:ShortPages
Closed, ResolvedPublic

Description

please Remove disambigiation pages from Special:ShortPages now it is useless and full of designation pages

Details

Reference
bz51124

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 2:09 AM
bzimport set Reference to bz51124.
bzimport added a subscriber: Unknown Object (MLST).
Yamaha5 created this task.Jul 10 2013, 5:21 PM

I think Reza means "disambiguation pages"

yes! Auto-correction changed my text :(

Looking at http://en.wikipedia.org/wiki/Special:ShortPages , I still don't know what the problem is exactly.
reza1615: Please provide steps / specific links in bug reports so it's easier to reproduce.

Steps to reproduce:

  1. Look at https://en.wikipedia.org/wiki/Special:ShortPages
  2. Click on a random article on the list: https://en.wikipedia.org/wiki/Meta-information
  3. Notice that this article is not an "article", but actually a disambiguation page.

Basically the bug report is that now that we can easily identify pages that are disambiguation pages with their page property, we should exempt those pages from being listed at Special:ShortPages since they aren't real articles.

Change 262680 had a related patch set uploaded (by Kaldari):
Add hook to allow extensions to modify query used by Special:ShortPages

https://gerrit.wikimedia.org/r/262680

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 6 2016, 12:06 AM
Addshore updated the task description. (Show Details)Jan 6 2016, 4:34 PM
Addshore set Security to None.

Change 262730 had a related patch set uploaded (by Kaldari):
Exclude disambiguation pages from Special:ShortPages

https://gerrit.wikimedia.org/r/262730

Change 262680 merged by jenkins-bot:
Add hook to allow extensions to modify query used by Special:ShortPages

https://gerrit.wikimedia.org/r/262680

Change 262730 merged by jenkins-bot:
Exclude disambiguation pages from Special:ShortPages

https://gerrit.wikimedia.org/r/262730

kaldari closed this task as Resolved.Jan 6 2016, 8:26 PM
kaldari claimed this task.
kaldari moved this task from Untriaged to Archive on the Community-Tech board.
Nemo_bis added a subscriber: Nemo_bis.EditedFeb 5 2016, 7:17 AM

On some wikis, like the Italian Wikipedia, this change curiously had the opposite effect short-term, because disambiguation pages which were previously considered big are now (correctly) listed as short. Anyway, adding __DISAMBIG__ should fix things now.
https://it.wikipedia.org/wiki/Wikipedia:Bar/Discussioni/Cosa_%C3%A8_successo_alle_pagine_pi%C3%B9_corte_%3F

Moroboshi added a subscriber: Moroboshi.EditedFeb 5 2016, 1:30 PM

On some wikis, like the Italian Wikipedia, this change curiously had the opposite effect short-term, because disambiguation pages which were previously considered big are now (correctly) listed as short. Anyway, adding __DISAMBIG__ should fix things now.
https://it.wikipedia.org/wiki/Wikipedia:Bar/Discussioni/Cosa_%C3%A8_successo_alle_pagine_pi%C3%B9_corte_%3F

Articles dedicated to Year, Decade or Century are not disambiguation, they compare on Special:ShortList on it.wiki simply because in many of them the only real content of the article are the layout/navigation templates.

@Moroboshi: I'm a bit confused. It sounds like Speciale:PaginePiùCorte is actually working correctly. The year articles have no content and are not disambiguation pages, so it seems like they should be listed there. The discussion linked to above mentions "short page patrolling". Apparently short page patrolling is not simply looking for short pages, but something different. What is the goal of short page patrolling? Perhaps there should be a different type of special page that is designed to facilitate whatever that goal is.

@Kaldary, yes it's working correctly on it.wiki, Nemo was wrong in signaling this as a problem.

Some patroller on it.wiki check the Short Page special list because sometimes very short new page are created from new user by error or are result of a vandal deleting page content. Previously page on year/decade/century were not include in the short page list because the layout/navigation template size was included in the page size. Now it's not included and this page are correctly listed.

Nemo thought that year/article/decade articles en.wiki are not listed because they are disambiguation pages so he marked year/century/decade page on it.wiki as disambiguation. In reality on en.wiki they simply have more content so they are not listed on short page list (or at least they are not listed in the first positions).

Nemo_bis added a comment.EditedFeb 14 2016, 10:55 AM

Nemo was wrong in signaling this as a problem

I said the opposite, «are now (correctly) listed as short».

Nemo thought that year/article/decade articles en.wiki are not listed because they are disambiguation pages

No, I didn't.