References inside templates don't appear in the reference list in VisualEditor
Closed, ResolvedPublic

Description

When viewed in edit mode, references included in an infobox are not included in the references list at the bottom of the article, and the first reference in the body of an article is numbered stating from 1, ignoring any in the infobox.

Example articles: w:en:Popocatépetl and [[East Toowoomba, Queensland]].

Possibly related to T52474 and/or T52479

See Also:
T54398
T52474
T52749
T54427
T55486
T52896

Details

Reference
bz51289
bzimport set Reference to bz51289.

Sorry, that second possibly related bug should be bug 50749

This is now fixed due to the same fixes as bug 51741 (and in Parsoid) - they're still numbered wrongly (which is bug 50474).

Mike Christie at en.wp has reported this happening with notes defined in image captions. Will the fix for this bug solve that when it is deployed or should I file a separate bug?

(In reply to comment #3)

Mike Christie at en.wp has reported this happening with notes defined in
image captions. Will the fix for this bug solve that when it is deployed or
should I file a separate bug?

This is now deployed; references in image captions sounds like a further bug, sadly.

Ok thanks for the quick reply, now reported as bug 52427

This has started happening again. See [[OpenOffice.Org]] and [[Bristol]] for examples.

Also, as seen by editing https://en.wikipedia.org/w/index.php?oldid=596381198 you cannot re-use any references that are within an infobox.

  • Bug 69066 has been marked as a duplicate of this bug. ***
Jdforrester-WMF lowered the priority of this task from "High" to "Normal".Jan 9 2015, 10:55 PM
Neil_P._Quinn_WMF changed the title from "VisualEditor: [Regression] References in templates don't appear in references list" to "VisualEditor: References inside templates don't appear in references list".Jun 16 2015, 12:30 AM
Neil_P._Quinn_WMF edited the task description. (Show Details)
Neil_P._Quinn_WMF edited the task description. (Show Details)
Neil_P._Quinn_WMF changed the title from "VisualEditor: References inside templates don't appear in references list" to "References inside templates don't appear in the reference list in VisualEditor".Jun 16 2015, 1:34 AM
Neil_P._Quinn_WMF edited the task description. (Show Details)
Neil_P._Quinn_WMF added a project: Epic.

This seems to be fixed, although T52474 (which is similar) remains open.

Neil_P._Quinn_WMF closed this task as "Resolved".Jun 16 2015, 1:56 AM

Add Comment