References inside templates don't appear in the reference list in VisualEditor
Closed, ResolvedPublic

Description

When viewed in edit mode, references included in an infobox are not included in the references list at the bottom of the article, and the first reference in the body of an article is numbered stating from 1, ignoring any in the infobox.

Example articles: w:en:Popocatépetl and [[East Toowoomba, Queensland]].

Possibly related to T52474 and/or T52479

See Also:
T54398
T52474
T52749
T54427
T55486
T52896

bzimport added a project: VisualEditor-DataModel.Via ConduitNov 22 2014, 1:52 AM
bzimport set Reference to bz51289.
Thryduulf created this task.Via LegacyJul 13 2013, 1:38 PM
Thryduulf added a comment.Via ConduitJul 13 2013, 1:39 PM

Sorry, that second possibly related bug should be bug 50749

Jdforrester-WMF added a comment.Via ConduitAug 1 2013, 7:02 PM

This is now fixed due to the same fixes as bug 51741 (and in Parsoid) - they're still numbered wrongly (which is bug 50474).

Thryduulf added a comment.Via ConduitAug 1 2013, 10:48 PM

Mike Christie at en.wp has reported this happening with notes defined in image captions. Will the fix for this bug solve that when it is deployed or should I file a separate bug?

Jdforrester-WMF added a comment.Via ConduitAug 1 2013, 10:54 PM

(In reply to comment #3)

Mike Christie at en.wp has reported this happening with notes defined in
image captions. Will the fix for this bug solve that when it is deployed or
should I file a separate bug?

This is now deployed; references in image captions sounds like a further bug, sadly.

Thryduulf added a comment.Via ConduitAug 1 2013, 11:04 PM

Ok thanks for the quick reply, now reported as bug 52427

Thryduulf added a comment.Via ConduitSep 21 2013, 7:03 PM

This has started happening again. See [[OpenOffice.Org]] and [[Bristol]] for examples.

Jdforrester-WMF added a comment.Via ConduitSep 24 2013, 11:59 PM

Gah.

Whatamidoing-WMF added a comment.Via ConduitFeb 20 2014, 7:49 PM

Also, as seen by editing https://en.wikipedia.org/w/index.php?oldid=596381198 you cannot re-use any references that are within an infobox.

Jdforrester-WMF added a comment.Via ConduitAug 3 2014, 10:20 AM
  • Bug 69066 has been marked as a duplicate of this bug. ***
Jdforrester-WMF moved this task to Backlog on the VisualEditor workboard.Via WebNov 24 2014, 1:28 AM
Jdforrester-WMF lowered the priority of this task from "High" to "Normal".Via WebJan 9 2015, 10:55 PM
Mattflaschen removed a subscriber: Mattflaschen.Via EmailJan 15 2015, 2:00 AM
matmarex set Security to None.
Trizek-WMF added a subscriber: Trizek-WMF.Via WebJun 1 2015, 9:01 PM
Neil_P._Quinn_WMF changed the title from "VisualEditor: [Regression] References in templates don't appear in references list" to "VisualEditor: References inside templates don't appear in references list".Via WebTue, Jun 16, 12:30 AM
Neil_P._Quinn_WMF edited the task description. (Show Details)
Neil_P._Quinn_WMF edited the task description. (Show Details)
Neil_P._Quinn_WMF changed the title from "VisualEditor: References inside templates don't appear in references list" to "References inside templates don't appear in the reference list in VisualEditor".Via WebTue, Jun 16, 1:34 AM
Neil_P._Quinn_WMF edited the task description. (Show Details)
Neil_P._Quinn_WMF added a project: Epic.

This seems to be fixed, although T52474 (which is similar) remains open.

Neil_P._Quinn_WMF closed this task as "Resolved".Via WebTue, Jun 16, 1:56 AM

Add Comment