Page MenuHomePhabricator

VisualEditor: If running on an old MW so jquery.client doesn't have what we need, don't just fail silently
Closed, ResolvedPublic

Description

Right now lots of users try VE with MW 1.21.x and are confused as to why they get nothing.


Version: unspecified
Severity: minor

Details

Reference
bz51606

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 1:45 AM
bzimport set Reference to bz51606.

Is MW >= 1.22 a requirement? If so we can check wgVersion and throw an exception

http://www.mediawiki.org/wiki/Extension:VisualEditor says yes.

I'm not familiar with how extensions usually check for MW version compatibility. Obviously we could do it in the client and throw a JS exception, but there may a preferred way in PHP?

Digging around I assume wfUseMW( '1.22alpha' )?

Change 76706 had a related patch set uploaded by Esanders:
Check MW version before loading VE

https://gerrit.wikimedia.org/r/76706

Change 76706 merged by jenkins-bot:
Check MW version before loading VE

https://gerrit.wikimedia.org/r/76706

Change 76869 had a related patch set uploaded by Jforrester:
Add dependency check for MW1.22/wmf11

https://gerrit.wikimedia.org/r/76869

Change 76869 merged by jenkins-bot:
Add dependency check for MW1.22/wmf11

https://gerrit.wikimedia.org/r/76869

This is now merged.