Page MenuHomePhabricator

Page actions are wrong for VisualEditor
Open, MediumPublic

Description

mw.gettingStarted.logging.getPageSchemaAction returns the wrong values for VE. For instance, it returns page-impression when the VE edit screen is open.


Version: unspecified
Severity: normal

Details

Reference
bz51634

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:46 AM
bzimport set Reference to bz51634.

swalling wrote:

Would this impact page-save-success logging for VE?

Yes, good catch. VE doesn't touch wgPostEdit, which we're using, at all.

When this is fixed, we should also try to put back page-save-attempt and page-save-success for both (we might do it just for wikitext again in the meantime).

getPageSchemaAction has been removed entirely, so I'm tempted to close this. However, we will need to revisit if we want to track something like "edit impressions" again.

As part of the new VE tests we will need to have reliable instrumentation (adding Nuria and James to make sure they are aware of this change).

In T53634#544033, @Mattflaschen wrote:

getPageSchemaAction has been removed entirely, so I'm tempted to close this. However, we will need to revisit if we want to track something like "edit impressions" again.

@Halfak: Still working on this? If yes what's the progress, if no should the assignee be reset and is "high priority" still correct here?

@Aklapper Hmm.. This should not be assigned to me. I'm not sure how that happen.

@Aklapper Hmm.. This should not be assigned to me. I'm not sure how that happen.

See https://old-bugzilla.wikimedia.org/show_bug.cgi?id=51634 - it was assigned to you in 02/2014.

Unassigning (you can also do that) and lowering priority here.

Aklapper lowered the priority of this task from High to Medium.
Aklapper set Security to None.