Page MenuHomePhabricator

VisualEditor: Rich content copied from sub-documents (image captions, references, etc.) down-cast to plain text when the sub-document is closed
Closed, ResolvedPublic

Description

Author: lunarjam.mcgahan

Description:
Wikipedia VE bug Reference with no parameter tags not editable in Chrome on Win7

See attached Word document Wikipedia VE bug Reference with no parameter tags not editable in Chrome on Win7


Version: unspecified
Severity: normal

Attached:

Details

Reference
bz51725

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 1:52 AM
bzimport set Reference to bz51725.
bzimport created this task.Jul 20 2013, 1:59 AM

The contents of the attached Word document, to the extent that LibreOffice will display them, seem to be:

The source code is as follows:
<ref>[http://gypsywaggons.co.uk/varhistory.htm "History of the Vardo (Gypsy Caravan)"], ValleyStream Media, 2009</ref>

Was there a screenshot that you meant to include? Could you give us a link to the article? Could you explain the problem in more detail?

That ref is only on one page, in English and Thai
https://www.google.com.au/search?q="History of the Vardo"+site:wikipedia.org

And I was able to do a basic edit to that ref on Chrome Version 28.0.1500.72 m/Windows 7 Enterprise SP1, in Vector and Monobook

https://en.wikipedia.org/w/index.php?title=Recreational_vehicle&diff=565400866&oldid=565097139

https://en.wikipedia.org/w/index.php?title=Recreational_vehicle&diff=565401640&oldid=565400866

https://th.wikipedia.org/w/index.php?diff=5049776&oldid=4731458

There must be something more specific needed to reproduce this.

lunarjam.mcgahan wrote:

Further information

See attachment Bug 51725 further explanation

Attached:

This is similar to bug 33105 and bug 41193, but this bug is more specific as it is within the same window.

Steps to reproduce:

  1. Create a reference with '[http:example.com example], publisher, year'
  2. Open dialog for reference created in step 1
  3. Copy the richtext reference and close the dialog
  4. Insert reference anywhere, and paste the clipboard

Results:
Plain text paste 'example, publisher, year'

Expected results:
Richtext paste '[http:example.com example], publisher, year'

  • Bug 65593 has been marked as a duplicate of this bug. ***
Pols12 added a subscriber: Pols12.Dec 17 2015, 9:59 PM

Today it seems to work well. (Firefox 42)
Or I have not undestood.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptDec 17 2015, 9:59 PM
matmarex closed this task as Resolved.Aug 31 2018, 4:07 PM
matmarex added a subscriber: matmarex.

Indeed, this seems to no longer be a problem (testing the reproduction steps by @jayvdb). Rich text is correctly pasted.

Restricted Application added a project: User-Ryasmeen. · View Herald TranscriptAug 31 2018, 4:07 PM