Search for single unicode symbol causes error without explanation
Closed, ResolvedPublic

Assigned To
None
Priority
Needs Triage
Author
jayvdb
Subscribers
Schnark, jayvdb, Manybubbles, wikibugs-l
Projects
Reference
bz51790
Description

Go to

https://en.wikipedia.org/w/index.php?title=Special%3ASearch&profile=advanced&search=%E2%99%99&fulltext=Search&ns0=1&profile=advanced

Error:

An error has occurred while searching: The search backend returned an error:

(but no error message is displayed)


Version: unspecified
Severity: normal

bzimport added a project: MediaWiki-Search.Via ConduitNov 22 2014, 1:57 AM
bzimport added a subscriber: wikibugs-l.
bzimport set Reference to bz51790.
jayvdb created this task.Via LegacyJul 22 2013, 1:59 AM
jayvdb added a comment.Via ConduitJul 22 2013, 2:06 AM

The same occurs for most symbols that I've tried, including proper character sets like
https://en.wikipedia.org/wiki/Template:Unicode_chart_Myanmar

However adding a ascii character after the symbol '(symbol)a' fixes the problem.

https://en.wikipedia.org/w/index.php?title=Special%3ASearch&profile=advanced&search=%E2%99%99a&fulltext=Search&ns0=1&profile=advanced

Aklapper added a comment.Via ConduitJul 22 2013, 9:20 AM

This sounds like a duplicate of bug 51661 to me.

  • This bug has been marked as a duplicate of bug 51661 ***
Schnark added a comment.Via ConduitJul 22 2013, 9:41 AM

Letters from Myanmar Unicode block work for me (https://en.wikipedia.org/w/index.php?search=%E1%80%80&title=Special%3ASearch&fulltext=1). This isn't a duplicate of bug 51661, but of bug 47770.

  • This bug has been marked as a duplicate of bug 47770 ***
Aklapper added a comment.Via ConduitJul 22 2013, 10:44 AM

Michael: Thanks for correcting me. Appreciated!

Add Comment