[[ or ]] in the middle of a link are not <nowiki>ed
Closed, ResolvedPublic

Description

English Wikipedia user Atethnekos reports:
"If I type "Fra]]nce" and then select that entire text and make it a link to [[France]], after I save it, the link anchor ends up appearing just as "France" followed by a non-anchor "]]""

The wikitext saved is: Three men from [[France|Fra]]nce]] went to sea.

But it displays in view mode and subsequent edits as: Three men from [[France]]]] when to sea.

{{ and }} in the middle of links are nowiki-ed but [[ is not.

https://en.wikipedia.org/w/index.php?title=User:Thryduulf/sandbox&diff=565594034&oldid=565593016


Version: unspecified
Severity: normal

bzimport added a project: Parsoid-Serializer.Via ConduitNov 22 2014, 2:07 AM
bzimport set Reference to bz51944.
Thryduulf created this task.Via LegacyJul 24 2013, 9:54 AM
Jdforrester-WMF added a comment.Via ConduitJul 24 2013, 3:28 PM

Parsoid issue, presumably?

ssastry added a comment.Via ConduitJul 24 2013, 3:30 PM

Heh ... for a change, this bug report is asking for nowikis ;-)

Jdforrester-WMF added a comment.Via ConduitJul 24 2013, 3:31 PM

(In reply to comment #2)

Heh ... for a change, this bug report is asking for nowikis ;-)

Indeed. :-)

gerritbot added a comment.Via ConduitJan 14 2014, 10:41 PM

Change 107491 had a related patch set uploaded by Subramanya Sastry:
(Bug 51944) Tweaks to wikitext escaping of [[ and ]] in link text

https://gerrit.wikimedia.org/r/107491

gerritbot added a comment.Via ConduitJan 14 2014, 11:53 PM

Change 107491 merged by jenkins-bot:
(Bug 51944) Tweaks to wikitext escaping of [[ and ]] in link text

https://gerrit.wikimedia.org/r/107491

Add Comment