Page MenuHomePhabricator

Scribunto should notify the installer if lua can't run because it isn't executable
Closed, ResolvedPublic

Description

After uploading MW and Scribunto via FTP to free GoDaddy hosting, it wouldn't work. I spent several hours trouble shooting before I discovered the cause: the bundled.binaries didn't have the executable bit set.


Version: master
Severity: normal

Details

Reference
bz52002

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:43 AM
bzimport set Reference to bz52002.
bzimport added a subscriber: Unknown Object (MLST).

Change 75819 had a related patch set uploaded by MarkAHershberger:
Scribunto should error out sooner if lua isn't executable Improve error reporting by causing Scribunto to fail earlier if lua can't be run.

https://gerrit.wikimedia.org/r/75819

Change 75819 merged by jenkins-bot:
Scribunto should error out sooner if lua isn't executable

https://gerrit.wikimedia.org/r/75819

Hi since adding this change it seems to be having an error with my wiki it used to work before this change please fix it

paladox2015: If you'd like somebody to investigate then you should provide way more information than "having an error with my wiki", plus explain why you think that it's related. See https://www.mediawiki.org/wiki/How_to_report_a_bug

Well when I go on my wiki http://random-wikisaur.tk and type module:documentation and then typed --start and click save it would show an error when the extension is having problems running it didn't show this error before until now

Could you separate your steps (and sentences) by using punctuation marks?
Have you asked on https://www.mediawiki.org/wiki/Project:Support_desk ?
Still no idea what your error message is, still no idea why you think this is related to this bug report. Again, see https://www.mediawiki.org/wiki/How_to_report_a_bug

And the error itself is what? Please copy and paste the entire error from your logs.

Also, if you can identify which Lua binary is being used (which you will be able to do if it is due to this change), please execute "ls -l /path/to/the/binary" from a shell on the server and include that here too.

Error is [95870313] 2013-09-06 19:04:48: Fatal exception of type MWException and I doint have access to ssh due to my host blocking it due to security

(In reply to comment #8)

Error is [95870313] 2013-09-06 19:04:48: Fatal exception of type MWException

See http://www.mediawiki.org/wiki/Manual:How_to_debug

and I doint have access to ssh due to my host blocking it due to security

Then there might be nothing we can help with. Please ask on the Support Desk.

Change 95419 had a related patch set uploaded by MarkAHershberger:
Scribunto should error out sooner if lua isn't executable

https://gerrit.wikimedia.org/r/95419

Change 95419 abandoned by MarkAHershberger:
Scribunto should error out sooner if lua isn't executable

https://gerrit.wikimedia.org/r/95419

No open patches to review here (backport patches got abandoned), hence resetting status to RESOLVED FIXED. Backport_to_Stable flag might be set to "-" by hexmode.