Page MenuHomePhabricator

VisualEditor: Media insertion dialog should display a message if no media is found for the given search
Closed, ResolvedPublic

Description

en.wp user:Wouterstomp asks.
"When no image is found, please display a message saying so, now it looks like nothing is happening (especially [if you] missed the short busy animation of the search bar)"
The context is the image insertion dialog.


Version: unspecified
Severity: trivial

Details

Reference
bz52463

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:47 AM
bzimport set Reference to bz52463.
Thryduulf created this task.Aug 2 2013, 4:26 PM

Given the fact that users often want to add the image that they just uploaded, and that Commons's search is fairly often taking a couple of days to "notice" that these images exist, the default message on wikis that use Commons should say something like "No image was found. If you just uploaded an image with this name, this may be due to the image not being indexed in Commons's search database yet. Please try again in a couple of days."

It might also be worth linking to a help page that describes limitations in the search protocol. For example, it will find images if I give it the whole name ("2013AliceAndBob") but not if I give it just the start of the name ("2013Alice").

  • Bug 60932 has been marked as a duplicate of this bug. ***

WhatamIdoing, there is a design that has not been implemented yet for the image dialog that allow quick access to users uploads, perhaps in the case of zero search results, we can automatically show that mode.

Change 133050 had a related patch set uploaded by Mooeypoo:
If no media is found display a message in media insert dialog

https://gerrit.wikimedia.org/r/133050

Change 133050 merged by jenkins-bot:
If no media is found display a message in media insert dialog

https://gerrit.wikimedia.org/r/133050

The message "No results found" stays in the dialog even if user changed the search string and the matched images appear inside the dialog.See the screenshot attached

Created attachment 15419
Screenshot

Attached:

Change 133858 had a related patch set uploaded by Mooeypoo:
Hide 'no results found' once there's at least one result

https://gerrit.wikimedia.org/r/133858

Change 133858 merged by jenkins-bot:
Hide 'no results found' once there's at least one result

https://gerrit.wikimedia.org/r/133858

Change 133864 had a related patch set uploaded by Jforrester:
Hide 'no results found' once there's at least one result

https://gerrit.wikimedia.org/r/133864

Change 133864 merged by jenkins-bot:
Hide 'no results found' once there's at least one result

https://gerrit.wikimedia.org/r/133864

Verified the fix in Betalabs

Verified in production