Page MenuHomePhabricator

Requesting adding AdorshoLipi font for Bangla
Closed, DeclinedPublic

Description

Please add the AdorshoLipi font from OmicronLab website. The link to download the font: http://www.omicronlab.com/download/fonts/AdorshoLipi_20-07-2007.ttf

I will get back to you with the licensing information soon.


Version: unspecified
Severity: enhancement

Details

Reference
bz52719

Event Timeline

bzimport raised the priority of this task from to Low.Nov 22 2014, 2:05 AM
bzimport set Reference to bz52719.
Reedy added a comment.Aug 11 2013, 5:15 AM

The website shows as being https://creativecommons.org/licenses/by-nc-sa/3.0/ so hopefully the fonts are too...

Hi Reedy,
You are right, the site contents are published under CC-BY-NC-SA license but all the fonts of that site are not developed by that site owners (or who are involved with it). It is a simple site where you will find some popular Bengali free fonts.

The font 'AdorshoLipi' is published under the GPL 2.0 or higher license. I just checked the font info (open the font in fort viewer and click the Info button) and found the following license information. As licence supports this option you may add this in the ULS.

``
Designed by: Partha sarathi Pal <p.s.pal.2006@gmail.com> This font is free software; you can redistribute it and/or modify it under the terms of the GNU General Public License as published by the Free Software Foundation; either version 2 of the License, or (at your option) any later version. This font is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License (http://www.gnu.org/licenses/gpl.txt), in the COPYING file for more details. As a special exception, if you create a document which uses this font, and embed this font or unaltered portions of this font into the document, this font does not by itself cause the resulting document to be covered by the GNU General Public License. This exception does not however invalidate any other reasons why the document might be covered by the GNU General Public License. If you modify this font, you may extend this exception to your version of the font, but you are not obligated to do so. If you do not wish to do so, delete this exception statement from your version.
``

--nasir khan

Thanks for checking up all the details. If you are inclined, you can also try to convert it to the appropriate formats for it to be easily added into Universal Language Selector. The documentation is here: https://www.mediawiki.org/wiki/Extension:UniversalLanguageSelector#Adding_fonts and has been updated recently. Thanks.

Arrbee added a comment.Oct 7 2013, 4:56 AM

The original author of the font Partha Sarathi Pal (not on bugzilla) has informed us of a newer version of the font file than the one hosted on omicronlab. This new version adds support Latin characters and numbers. It would better to include this newer version. Currently, we are trying to procure this newer version (either through an publicly available link or attached to this bug) as it is only available with the author.

Is it latest version,as you said earlier?(In reply to comment #5)

Repository: https://github.com/shabab/AdorshoLipi-font

Change 88495 had a related patch set uploaded by KartikMistry:
Add AdorshoLipi font for Bangla

https://gerrit.wikimedia.org/r/88495

Patch tested. Works well with Firefox and Chrome.

Tanvir, Nasir, Jayanta,

Can you please confirm that there is a community consensus for this font to be made available for use? A link to a discussion or a discussion on this bug will be fine.

We are done with the testing (you are welcome to test some more) and can push it into the repo once we get a nod that the Bangla user community will not object to having another font. Thanks.

Runa

Initiated a discussion at Bangla Wikimedia Village Pump.
Link: http://is.gd/KMkk9A

Hi, Runa , Please wait minimum 15 days. one request from VP discussion, can we see the test page where patch tested?

(In reply to comment #12)

Hi, Runa , Please wait minimum 15 days. one request from VP discussion, can
we
see the test page where patch tested?

We don't really have any page to test it. The tests were done on local wikis using the ULS patchset mentioned in comment #8 i.e. https://gerrit.wikimedia.org/r/88495.

I am adding a screenshot from the my tests. Thanks.

Created attachment 13482
screenshot of Adorsholipi font used with mediawiki

Attached:

Thanks for sharing the screenshot.

Form the screenshot i found that the 'Search Box' and the 'Search Buttons' are not in correct position. Do you think it is happening for this font?

(In reply to comment #15)

Thanks for sharing the screenshot.
Form the screenshot i found that the 'Search Box' and the 'Search Buttons'
are
not in correct position. Do you think it is happening for this font?

I could replicate this behaviour only on Firefox. Siyam Rupali on Firefox displays the widgets correctly (screenshot attached).

However, Adorsholipi on Chrome does not show the problem (screenshot attached).

Thanks.

Created attachment 13486
Using Siyam Rupali on Firefox

Attached:

Created attachment 13487
Using Adorsholipi on Chrome

Attached:

Nasir, Jayanta,

Do you have any update from the discussions? It seems to have stopped: http://is.gd/KMkk9A

Thanks
Runa

(In reply to comment #18)

Created attachment 13487 [details]
Using Adorsholipi on Chrome

(In reply to comment #20)

Nasir, Jayanta,
Do you have any update from the discussions? It seems to have stopped:
http://is.gd/KMkk9A
Thanks
Runa

Using Adorsholipi on Chrome "সম্প্রদায়ের প্রবেশদ্বার" not render properly. So we cant understand whether other "Juktakkhar" works or nor not, could you please provide any long article page?

Attached:

In the previous screenshots it shows that, this font breaks the style in the top right search box area. but i am not sure why the button styles were different for the font 'Siyam Rupali' and 'Adorsholipi'.

It would be better i can get full page screenshot.

Created attachment 13759
Adorshilipi used on a long section of text on firefox

The rendering is not broken here but a part of the text is hanging out of the search box.

Attached:

Created attachment 13760
Adorshilipi used on a long section of text on chrome

Rendering is broken more than before on chrome. I would probably like to see this tested on other platforms (Linux & Windows) before blaming it on chrome.

Attached:

Nasir, Jayanta, If you have local wiki's that you can use for testing, I can guide you on how to set the font there. Let me know if that works. Thanks

Hi Runa,
I can test this on my local machine. Could you please let me know the steps to reproduce this.

nasir

(In reply to comment #26)

I can test this on my local machine. Could you please let me know the steps
to
reproduce this.

Sent over e-mail. Thanks.

PLease cc to me!

Hello. Is this on? Please let's get some progress here, or we need to move on.

Shabab / Jayanta / Tanvir / Nasir:

The patch to add the AdorshoLipi font welcomes more testing from community as its glyphs (the way certain letters are displayed) might require more work.

To make it easier for you to test and compare the font, Runa said that she will try to make the link in http://kartik.profarius.com/tests/webfonts.html work again.

Is there anything else to help you and the Bangla community to provide feedback on the AdorshoLipi font, apart from making that comparison link work again?

Have / Could you ask the community on the local Village Pump / discussion page to please help testing the font and to add feedback in that thread on the discussion page? Afterwards, somebody could summarize (or translate the feedback to English if needed) and add it here in Bugzilla as a comment?

Thanks in advance for your help to get this font hopefully deployed soon to the entire community!

Shabab / Jayanta / Tanvir / Nasir: Please answer comment 31.

Hi Andre Klapper, Could you please add AdorshoLipi font again at http://kartik.profarius.com/tests/webfonts.html ?

@Nasir, http://kartik.profarius.com/tests/webfonts.html page is updated with AdorshoLipi now.

The font designer is not responding the on the issue of font scaling (https://github.com/shabab/AdorshoLipi-font/issues/1). So it is better to discrete the patch and not merge with the ULS.

Change 88495 abandoned by KartikMistry:
Add AdorshoLipi font for Bangla

Reason:
As discussed with users and See: https://github.com/shabab/AdorshoLipi-font/issues/1 Font can be readded when it is fixed upstream.

https://gerrit.wikimedia.org/r/88495

Set to assigned until bug(s) at upstream is fixed.

KartikMistry closed this task as Declined.Dec 5 2017, 4:35 AM

No update since 2014. We're deprecating webfonts feature where language has good support on modern operating systems now.