Data about oldest revisions of edit filters from (some?) WMF wikis is not available in the logs
Closed, ResolvedPublic

Description

We are not able to get logs for any of the 131 oldest AbuseFilter modifications on Portuguese Wikipedia:
https://pt.wikipedia.org/wiki/Special:AbuseFilter/history?offset=20090704151453&limit=131&uselang=en
either by the API query
https://pt.wikipedia.org/w/api.php?action=query&list=logevents&format=jsonfm&leprop=ids|title|type|user|userid|timestamp|comment|parsedcomment|details|tags&leaction=abusefilter/modify&ledir=newer&lelimit=1
or by the UI:
https://pt.wikipedia.org/wiki/Special:Log/abusefilter?dir=prev&uselang=en

Compare with
https://en.wikipedia.org/wiki/Special:Log/abusefilter?dir=prev
where the oldest log is from 17 March 2009, and corresponds to the oldest change listed in the AbuseFilter's history:
https://en.wikipedia.org/w/index.php?title=Special:AbuseFilter/history/&dir=prev
(I wasn't able to check the analogous API query for enwiki, because of T54918)

Would it be possible to run some maintenance script to add the missing changes to the logs of the affected WMF wikis? This would allow us to get this information from Wikipedias using the MediaWiki API.


Version: wmf-deployment
Severity: minor

Details

Reference
bz52919
bzimport raised the priority of this task from to Low.
bzimport set Reference to bz52919.
He7d3r created this task.Aug 16 2013, 12:27 PM

(In reply to comment #0)

Would it be possible to run some maintenance script to add the missing
changes
to the logs of the affected WMF wikis? This would allow us to get this
information from Wikipedias using the MediaWiki API.

One would have to exist first...

(In reply to comment #0)

Compare with
https://en.wikipedia.org/wiki/Special:Log/abusefilter?dir=prev
where the oldest log is from 17 March 2009, and corresponds to the oldest
change listed in the AbuseFilter's history:
https://en.wikipedia.org/w/index.php?title=Special:AbuseFilter/history/
&dir=prev
(I wasn't able to check the analogous API query for enwiki, because of bug

Hmm... Actually, these 1108 entries
https://en.wikipedia.org/w/index.php?title=Special:AbuseFilter/history&offset=20090703235800&limit=1108
are missing from enwiki's log:
https://en.wikipedia.org/wiki/Special:Log/abusefilter?dir=prev

Caused by r48501 deployed around 2009-03-17, fixed from deployment of r52734 on 2009-07-03 (this bug is about fixing up the entries made in between)

Change 85675 had a related patch set uploaded by Alex Monk:
Add maintenance script to restore missing log entries for each filter history entry

https://gerrit.wikimedia.org/r/85675

He7d3r set Security to None.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptAug 11 2015, 7:57 PM
Restricted Application added a subscriber: Luke081515. · View Herald TranscriptAug 11 2015, 7:57 PM

I've encountered some issues with the script and will need to make a small change

Change 233174 had a related patch set uploaded (by Alex Monk):
Fix addMissingLoggingEntries maintenance script handling of newlines

https://gerrit.wikimedia.org/r/233174

Change 233174 merged by jenkins-bot:
Fix addMissingLoggingEntries maintenance script handling of newlines

https://gerrit.wikimedia.org/r/233174

Change 233176 had a related patch set uploaded (by Alex Monk):
No longer call removed SpecialPage::getLocalPageForName

https://gerrit.wikimedia.org/r/233176

Change 233176 merged by jenkins-bot:
No longer call removed SpecialPage::getLocalPageForName

https://gerrit.wikimedia.org/r/233176

Krenair closed this task as Resolved.Aug 22 2015, 11:36 PM

alswiki: Inserted 181 rows.
arwiki: Inserted 67 rows.
commonswiki: Inserted 149 rows.
dewiki: Inserted 132 rows.
elwiki: Inserted 171 rows.
enwiki: Inserted 2292 rows.
enwikinews: Inserted 20 rows.
enwikiquote: Inserted 48 rows.
enwikisource: Inserted 50 rows.
fiwiki: Inserted 90 rows.
hewiki: Inserted 209 rows.
hiwiki: Inserted 1 rows.
ltwiki: Inserted 30 rows.
mediawikiwiki: Inserted 5 rows.
metawiki: Inserted 115 rows.
nlwiki: Inserted 168 rows.
nlwikibooks: Inserted 10 rows.
plwiki: Inserted 99 rows.
ptwiki: Inserted 130 rows.
ruwiki: Inserted 327 rows.
simplewiki: Inserted 1 rows.
svwiki: Inserted 87 rows.
testwiki: Inserted 274 rows.
ukwiki: Inserted 17 rows.
usabilitywiki: Inserted 7 rows.
zh_yuewiki: Inserted 80 rows.
zhwiki: Inserted 497 rows.

He7d3r updated the task description. (Show Details)Aug 23 2015, 2:17 PM

Mentioned in SAL (#wikimedia-releng) [2018-02-12T18:48:22Z] <Hauskatze> Restoring first missing log entries on Beta refs. T54919