Page MenuHomePhabricator

VisualEditor: be & be-tarask locales need a different i18n Bold toolbar icon
Closed, ResolvedPublic

Description

Author: p.selitskas

Description:
Please create an icon with bold cyrillic "Т" for [be] and [be-tarask].

In Belarusian locales ([be] and [be-tarask]), the Bold icon is now read as "Тл" which may be interpreted as "Тлусты" (fat), but in fact it makes the selected text not fat, but bold ("Тоўсты"). :)


Version: unspecified
Severity: normal

Details

Reference
bz53094

Event Timeline

bzimport raised the priority of this task from to Normal.Nov 22 2014, 2:02 AM
bzimport set Reference to bz53094.
bzimport created this task.Aug 20 2013, 2:01 PM

We don't currently support [be], just [be-tarask]. Can you confirm that we should use the same icons for [be] (bold: T, italic: K)?

Change 80049 had a related patch set uploaded by Esanders:
Change be-tarask to use Te instead of Te-El for bold

https://gerrit.wikimedia.org/r/80049

p.selitskas wrote:

(In reply to comment #1)

We don't currently support [be], just [be-tarask]. Can you confirm that we
should use the same icons for [be] (bold: T, italic: K)?

Yes, I confirm this suggestion.

Change 80049 merged by jenkins-bot:
Change be-tarask to use Te instead of Te-El for bold

https://gerrit.wikimedia.org/r/80049

The be-tarask icons are now changed (and this version of the software will go out in a few hours' time); keeping the bug open for making it work with both be and be-tarask, as part of a general fall-back mode.

Now merged and will go out in about an hour.

p.selitskas wrote:

Class .ve-ui-icon-bold-cyrl-te-el was not created/generated, and now there is empty space instead of a "Bold" icon. Reopening the bug.

te-el shouldn't exist as it was replaced with just te, so maybe this is a caching issue?

p.selitskas wrote:

(In reply to comment #9)

te-el shouldn't exist as it was replaced with just te, so maybe this is a
caching issue?

https://bits.wikimedia.org/static-1.22wmf16/extensions/VisualEditor/modules/ve/ui/styles/images/icons/bold-cyrl-te-el.svg

404 (PNG as well). And I'm not counting the absent CSS class that should display this icon. Did the deployment come smoothly? :)

p.selitskas wrote:

(In reply to comment #10)

(In reply to comment #9)

te-el shouldn't exist as it was replaced with just te, so maybe this is a
caching issue?

https://bits.wikimedia.org/static-1.22wmf16/extensions/VisualEditor/modules/
ve/ui/styles/images/icons/bold-cyrl-te-el.svg
404 (PNG as well). And I'm not counting the absent CSS class that should
display this icon. Did the deployment come smoothly? :)

Oh, I'm sorry, I checked the wrong file. Anyway, JS adds the wrong class.

Looks like Trevor's toolbar rewrite didn't merge cleanly with my commits and they were partially undone.

p.selitskas wrote:

(In reply to comment #12)

Looks like Trevor's toolbar rewrite didn't merge cleanly with my commits and
they were partially undone.

Obviously. I was not aware of the rewrite and first thought that the patch was merged but hasn't appeared in the codebase (black magic).

Change 84027 had a related patch set uploaded by Esanders:
Fix merge conflict breaking localised bold/italic icons

https://gerrit.wikimedia.org/r/84027

Change 84027 merged by jenkins-bot:
Fix merge conflict breaking localised bold/italic icons

https://gerrit.wikimedia.org/r/84027

Argh, sorry about this mess; we'll back-port the fix.

p.selitskas wrote:

(In reply to comment #17)

Argh, sorry about this mess; we'll back-port the fix.

Thanks for swift resolving! Does it mean the 'fix fix' will be deployed soon out of general deployment schedule?

You're welcome. It does.

Change 84095 had a related patch set uploaded by Catrope:
Fix merge conflict breaking localised bold/italic icons

https://gerrit.wikimedia.org/r/84095

Change 84095 merged by jenkins-bot:
Fix merge conflict breaking localised bold/italic icons

https://gerrit.wikimedia.org/r/84095

Change 84361 had a related patch set uploaded by Reedy:
Fix merge conflict breaking localised bold/italic icons

https://gerrit.wikimedia.org/r/84361

Change 84361 merged by jenkins-bot:
Fix merge conflict breaking localised bold/italic icons

https://gerrit.wikimedia.org/r/84361

This should now be fixed in production; sorry for the delay.