Page MenuHomePhabricator

Special:ListDatatypes and Special:NewProperty are not consistent
Closed, ResolvedPublic

Description

https://test.wikidata.org/wiki/Special:ListDatatypes right now has URL as an available datatype but https://test.wikidata.org/wiki/Special:NewProperty does not. They should show the same list.


Version: master
Severity: normal
Whiteboard: u=dev c=backend p=0

Details

Reference
bz53265

Event Timeline

bzimport raised the priority of this task from to Low.
bzimport set Reference to bz53265.
bzimport added a subscriber: Unknown Object (MLST).
jayvdb added a comment.Jun 9 2014, 7:06 AM

URL now appears in both. Close this bug, or are there two underlying lists that still need to be merged?

Thanks for checking :)

The issue is that one of them shows what is actually configure on the wiki and the other one shows what is available in the code. This can lead to the case where a datatype is available but not enabled. It'd be shown in ListDatatypes but not NewProperty for no apparent reason. That's confusing. As far as I know that issue is still there.

Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Lydia_Pintscher removed a subscriber: Unknown Object (MLST).
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 27 2015, 10:35 AM
Addshore closed this task as Declined.Dec 4 2015, 12:55 PM
Addshore claimed this task.
Addshore added a subscriber: Addshore.

Special:ListDatatypes is maintained using i18n messages of all possible types
the list on Special:NewProperty is created using the currently enabled types.

I don't really think this is an issue.

Lydia_Pintscher reopened this task as Open.Dec 4 2015, 6:04 PM

It is an issue because it is confusing people when a datatype is "available" but not configured for a wiki so they can't use it.

Addshore closed this task as Resolved.EditedDec 4 2015, 8:52 PM

So I looked into this a bit more and the page should actually only show things registered in $wgWBRepoDataTypes
Which only contains datatypes that are enabled on the repo.

Special:NewPropertty gets its list from the same place

This was either fixed since this was filed, or it was not a real issue before and it may have had something to do with experimental datatypes etc.