VisualEditor: adding section for references will suppress the Related Articles one
Closed, ResolvedPublic

Description

See https://it.wikipedia.org/w/index.php?title=Bisanzio_Lupis&diff=61160806&oldid=51778070 .

When creating a section for references and adding the relevant tag,
it will suppress the Related Articles section - just the heading, not the content.

I reproduced it easily in my sandbox by just adding the contents that you can see in the diff above.
Note that it is not related to the reference being added in the same edit; here for instance https://it.wikipedia.org/w/index.php?title=Utente%3AElitre_%28WMF%29%2FSandbox_VE&diff=61285258&oldid=61285224 it was added previously.

Thanks.


Version: unspecified
Severity: normal

Details

Reference
bz53699
bzimport raised the priority of this task from to Needs Triage.
bzimport set Reference to bz53699.
Elitre created this task.Sep 3 2013, 11:16 AM
Jdforrester-WMF changed the task status from Open to Stalled.Feb 2 2015, 7:24 PM
Risker added a subscriber: Risker.Feb 4 2015, 4:28 AM

I've attempted to reproduce the two test cases in a sandbox on the Italian Wikipedia. In both cases (full and reduced), adding the section heading and references list worked correctly.

When creating a section for references and adding the relevant tag,

What I tried:
Write the text "Notes" right above "Voci correlate", mark that text, choose "Heading" from the formatting dropdown, then add a reference via "Cite > Basic" somewhere in the text, then click below the "Notes" heading and choose "Insert > References list" in VE.

No issues either. Let's close this soon if noone can reproduce (already set to Stalled status).

Aklapper closed this task as Declined.Mar 4 2015, 4:41 PM
Aklapper claimed this task.

Closing task as declined as per last two comments as nobody managed to reproduce.

Please reopen if this problem still happens and provide an URL/link to an example. Thanks!

Risker removed a subscriber: Risker.Mar 5 2015, 2:21 AM
Elitre added a comment.Mar 6 2015, 2:45 PM

Yup, can't reproduce this one.

Neil_P._Quinn_WMF changed the task status from Declined to Resolved.EditedAug 3 2015, 6:49 PM

Making resolved instead because it probably was a problem in 2013 :)