Page MenuHomePhabricator

VisualEditor: Content disappears when using jquery.IME
Closed, ResolvedPublic8 Estimated Story Points

Description

System environment:
Win 7 X64
Google Chrome 29.0.1547.62 m

Steps to reproduce:
Open a blank page
Edit it in VE
Enable ULS IME hindi transliteration

Input 1:
agar[SPACE][ENTER/RETURN KEY]

Input 2:
kyaa[SPACE]

Expected output 1:
अगर[SPACE][NEWLINE]

Expected output 2:
क्या[SPACE]

Actual output 1:
[NEWLINE]

Actual output 2:
[SPACE]

For the first case, when the given characters are typed, everything is fine upto the pressing of the return key, ie agar[SPACE] gives अगर[SPACE] as expected. However, as soon as the return key is pressed the entire text disappears leaving only a newline.

For the second case, everything is fine till [SPACE] is pressed.

If the page is not blank, extreme weirdness occurs, which can only be explained with further bugs (which I'm about to file). In short though, the disappearances persist, along with other buggy effects.

Note: Page used for this test is [[:w:hi:सदस्य:Siddhartha Ghai/sandbox]]


Version: unspecified
Severity: normal

Details

Reference
bz53705

Event Timeline

bzimport raised the priority of this task from to Medium.Nov 22 2014, 1:46 AM
bzimport set Reference to bz53705.

The further weirdness mentioned above is explained in Bug 53706 and Bug 53708

There's code to address this bug in the following patch, which is due to go live by mediawiki.org on 13 September 2013:

https://gerrit.wikimedia.org/r/#/c/82858/

Please let us know whether it fixes the bug!

(In reply to comment #2)

There's code to address this bug in the following patch, which is due to go
live by mediawiki.org on 13 September 2013:

https://gerrit.wikimedia.org/r/#/c/82858/

Please let us know whether it fixes the bug!

The bug is not fixed. The behaviour for both the spaces specified in Comment 0 is still the same. Tested at https://www.mediawiki.org/wiki/User:Siddhartha_Ghai?veaction=edit

Here's the HTML which is in the result:

HTML for Input 1:

<div class="ve-ce-documentNode ve-ce-branchNode" contenteditable="true" spellcheck="true" lang="en" dir="ltr"><p class="ve-ce-branchNode"><span class="ve-ce-branchNode-slug ve-ce-branchNode-inlineSlug"></span></p><p class="ve-ce-branchNode"><span class="ve-ce-branchNode-slug ve-ce-branchNode-inlineSlug"></span></p></div>

HTML for Input 2:

<div class="ve-ce-documentNode ve-ce-branchNode" contenteditable="true" spellcheck="true" lang="en" dir="ltr"><p class="ve-ce-branchNode">&nbsp;</p></div>

(In reply to comment #3)

Here's the HTML which is in the result:

The above HTML is not entirely correct. Copy-pasting messed up the text nodes. I'll be adding screenshots for the html as seen in the chrome console.

HTML after input agar[SPACE]

Attached:

HTML after input agar[SPACE][ENTER/RETURN KEY]

Attached:

HTML after input kyaa

Attached:

HTML after input kyaa[SPACE]

Attached:

Hi,

Besides Marathi and Hindi I tested this bug for more indic languages like Bangla, Ahirani,Konkni, etc.

Even after defficulties I am trying to use VE+ULS combination on Marathi Wikipedia as much as possible to have real time feel and understand the issues better.

For an example on Marathi Wikipedia we do have a page https://mr.wikipedia.org/wiki/वॉर_अँड_पीस . Other than info box it is empty. In Hindi and Marathi Wikipedia we do have large(huge) number of pages which are almost empty.Not able to type first word itself is a major hindrance and challenge before VE+ULS combinations.

So wish and hope bug number 53700 and 53705 remain on priority list

rgds

As of https://gerrit.wikimedia.org/r/#/c/264577/ in UniversalLanguageSelector this should now be resolved and working for all users, and will be part of the wmf.12 release starting tomorrow.

Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJan 25 2016, 7:15 PM