Page MenuHomePhabricator

Notification icons are not ready for high-density displays (use SVG instead of PNG where supported)
Closed, ResolvedPublic

Description

screenshot of icon with blurry edges


Version: master
Severity: enhancement
See Also:
T55733: Use the same icons to represent the same things (tracking)
T56307: Watchlist icon does not match on desktop and mobile skin

Attached:

Details

Reference
bz53875

Event Timeline

bzimport raised the priority of this task from to High.Nov 22 2014, 1:58 AM
bzimport set Reference to bz53875.
bzimport added a subscriber: Unknown Object (MLST).

High quality SVGs are uploaded to commons and linked from here https://www.mediawiki.org/wiki/Echo_(Notifications)/Feature_requirements#Icons_and_types

Ping Nick W. with questions.

swalling wrote:

(In reply to comment #1)

High quality SVGs are uploaded to commons and linked from here
https://www.mediawiki.org/wiki/Echo_(Notifications)/
Feature_requirements#Icons_and_types
Ping Nick W. with questions.

Thanks!

I changed it from email just because it applies to all the notification icons. I'm also going to file a tracking bug for other icons that I know suffer from this issue.

The watch icon was pointed out a while back to sync with mobile, but it still hasn't been fixed, super ugly on desktop, can't find the bug, Quim might want to do these as GSoC tasks since they're quick and uncontroversial.

@Design: We do still need an update or replacement for

  • the "welcome (elsewhere)" icon (all projects that aren't WikiPedia)
  • the "default/fallback" (for non-WMF sites that use the extension)

Afaik, the rest of the "proposed" column are all approved by design and PM (I think Fabrice?), and ready to be switched. We just need a Product Manager to approve an engineer spending time actually implementing the switch.

Nick, thats why I mentioned Quim, I don't know that these changes are priority for any team, Echo is Maryana (Core features) not Fabrice, but Flow it priority for that team, so perhaps a community member or GSoC student can do all of these but the two you mentioned in question.

Qgil added a comment.Jan 28 2014, 4:41 AM

(In reply to comment #3)

The watch icon was pointed out a while back to sync with mobile, but it still
hasn't been fixed, super ugly on desktop, can't find the bug

See

Bug 35335 - Vector: Add SVG version of the watch star icon
Bug 54307 - Watchlist icon on does not match on desktop and mobile skin

Note: Google Code-in 2014 (the program of the many little tasks) was completed a few weeks back, and the next edition will start presumably on November. Google Summer of Code (the program if the few bigger projects) is not suitable for a task like this. Still, I just added the EASY keyword to iincrease its chances to be spotted by new contributors.

(In reply to comment #5)

I don't know that these changes are priority for any team

Then the priority of this bug should be low instead of high (or at least normal), since this field aims to simply reflect the current priorities.

Spage updated the task description. (Show Details)Feb 23 2015, 6:50 AM
Spage set Security to None.
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptOct 28 2015, 1:39 AM
Esanders renamed this task from Notification icons are not ready for high-density displays to Notification icons are not ready for high-density displays (use SVG instead of PNG where supported).Dec 19 2015, 12:54 PM
Volker_E added a subscriber: Pginer-WMF.EditedFeb 23 2016, 8:25 PM
Volker_E added a subscriber: Volker_E.

@Pginer-WMF How much of this is this still true?

@Pginer-WMF How much true is this still?

Not completely true.

The current notifications got extensively reviewed. I have been providing icons (in both SVG and PNG) for most of them.
So the most common notifications should be high-density-friendly.

Possibly missing:

  • Welcome message. One of the few "default" notifications that was not updated.
  • Icons for some specific extensions (e.g., education, gather) have not been updated as part of this process, but I don't know if they were already providing SVGs or not.
Qgil removed a subscriber: Qgil.Feb 24 2016, 10:26 AM
Mattflaschen-WMF closed this task as Resolved.Sep 21 2016, 4:34 AM
Restricted Application added a subscriber: TerraCodes. · View Herald TranscriptSep 21 2016, 4:34 AM

This was done, piece by piece.