Page MenuHomePhabricator

<api-error-stasherror>
Closed, ResolvedPublic

Description

Author: info

Description:
Screenshot of error

When using the Wikimedia Commons Upload Wizard today I got the error <api-error-stasherror> listed for each file when it came to adding the files (the stage after adding descriptions).

I was trying to add 5 files, and adding each of them to a new category as well as two other existing categories. The files are all jpeg images, around 40-100kB in size.

Browser is Google Chrome 29.0.1547.66 m


Version: unspecified
Severity: normal
See Also:
T56460: Missing message <api-error-stasherror> in connection with the UploadWizard

Attached:

Details

Reference
bz54028

Event Timeline

bzimport raised the priority of this task from to High.
bzimport set Reference to bz54028.
bzimport created this task.Sep 11 2013, 7:31 PM
bd808 added a comment.Sep 19 2013, 6:29 PM

(In reply to comment #0)

When using the Wikimedia Commons Upload Wizard today I got the error
<api-error-stasherror> listed for each file when it came to adding the files
(the stage after adding descriptions).

Do you by any chance have the "chunked upload" preference enabled on commons?

info wrote:

In the Upload Wizard preferences "Chunked uploads for files over 1MB in Upload Wizard" is unchecked. So no, unless there is another chunked upload setting somewhere else.

(In reply to comment #1)

(In reply to comment #0)
> When using the Wikimedia Commons Upload Wizard today I got the error
> <api-error-stasherror> listed for each file when it came to adding the files
> (the stage after adding descriptions).

Do you by any chance have the "chunked upload" preference enabled on commons?

I got the same error today and I have enabled the "chunked upload" preference.

But prior the above error I got the message "Bad token" for 1 of 5 files and after retrying to publish the missing 1 file I got the <api-error-stasherror> error.

I also experienced a similar issue yesterday when uploading this 132 Mb WebM video file with 'chunked upload' preferences enabled:

http://commons.wikimedia.org/wiki/File:Engagement_Roundtable_1_-_Part_2.webm

After my first attempt to upload that file, I got this message (see attached screenshots):

Internal error: Could not determine if the copy succeeded.

I refreshed my Contributions page, and there was no mention of this particular file upload, suggesting that this upload had not been successful.

I then clicked on 'Retry failed uploads', and got this second error message:

Unknown error: "stasherror"

I then clicked on 'Retry failed uploads' again, but that attempt was unsuccessful, even after a couple retries.

I then shut down my Mac Chrome 29 browser (which had 10 tabs open) and restarted the upload again from scratch, with fewer tabs. This time, the upload was successful, with no issues.

I should point out that I uploaded 9 other large video files yesterday with no issues either (and I kept adding more tabs throughout the day, which may rule out local browser memory allocation issues):
https://meta.wikimedia.org/wiki/Roundtables/Roundtable_1#Videos

All these uploads were done under the same conditions, both before and after the issue reported above. So this issue appears to be intermittent and difficult to reproduce.

Lastly, I should note that I experienced a similar issue last week, with this 453 Mb WebM video file:
https://meta.wikimedia.org/wiki/File:Multimedia_Roundtable_-_Part_1.webm

It gave me yet another error message ('An unknown error occurred'), but I was able to upload that file successfully, despite that message.

Created attachment 13396
Chunked-Upload-Wizard-Screenshot-Internal-Error-2013-09-26-2.17PM - See Comment 4 - first error message

Attached:

Created attachment 13397
Chunked-Upload-Wizard-Screenshot-Stash-Error-2013-09-26-2.20PM - See Comment 4, second error message

Attached:

Bryan Davis, is still in your plans to work on this? Now there are some nice scripts on Commons to make Special:UploadStash more usable, that could help you in debugging.

bd808 added a comment.Jan 5 2014, 10:57 PM

(In reply to comment #7)

Bryan Davis, is still in your plans to work on this? Now there are some nice
scripts on Commons to make Special:UploadStash more usable, that could help
you in debugging.

It's still on my list of "things to get to someday" but sadly I haven't looked at the problem of months. There is some hope however as the Multimedia team has been talking about a bug squash sprint for Upload Wizard.

Since the original reporter's files were way below 5MB and since I've seen the exact same bug experienced by a user who freshly created an account on one of our usertesting.com UX tests, I doubt that this one is caused by chunked uploads.

FYI I have two patches:

Together they should at least make it so errors from the stash API are legible and point to actual problems, instead of the illegible crap we've had thus far.

Gilles moved this task from Untriaged to Prototyping on the Multimedia board.Nov 24 2014, 3:56 PM
Gilles removed Gilles as the assignee of this task.Dec 2 2014, 9:13 AM
Steinsplitter moved this task from Incoming to Uploading on the Commons board.
Gilles moved this task from Prototyping to Untriaged on the Multimedia board.Apr 6 2015, 9:23 AM
Restricted Application added subscribers: Steinsplitter, Matanya. · View Herald TranscriptAug 16 2015, 9:11 AM
Jdforrester-WMF moved this task from Untriaged to Backlog on the Multimedia board.Sep 4 2015, 6:44 PM
matthiasmullie closed this task as Resolved.Mar 16 2017, 12:02 PM
matthiasmullie claimed this task.
matthiasmullie added a subscriber: matthiasmullie.

Since https://gerrit.wikimedia.org/r/#/c/328373/, UploadWizard will display parsed error messages straight from the API, so these illegible things can't happen anymore.
There's also been a lot of refactoring in UW data transfer.

It seems like back in 2013, multiple people were able to reproduce this bug. That is no longer the case now (and there is not enough info to further debug it at this point), and there haven't been updates here or elsewhere indicating this is still an issue.
I assume this issue has been adequately fixed by now. If the problem persists, please reopen!