Page MenuHomePhabricator

RTL for Notification Tool: ? should be ؟ icon
Closed, ResolvedPublic

Description

? should be ؟ icon

For Notification Tool for RTL languages Please change "?" icon in attached image to RTL icon

See @Amire80's comment. Not the same for all languages.


Version: unspecified
Severity: normal
See Also:
https://bugzilla.wikimedia.org/show_bug.cgi?id=54252

Attached:

Details

Reference
bz54276

Event Timeline

bzimport raised the priority of this task from to Needs Triage.Nov 22 2014, 1:57 AM
bzimport added projects: Notifications, I18n.
bzimport set Reference to bz54276.
bzimport added a subscriber: Unknown Object (MLST).
Yamaha5 created this task.Sep 18 2013, 2:28 PM

To devs:
You just need to add element like "#mw-echo-overlay-moreinfo-link" but with a "transform:scaleX(-1);" [1] to the ext.echo.overlay.css
and call that element instead the ltr one in ext.echo.overlay.js when .sitedir-rtl is true [2]

[1]: http://nicolasgallagher.com/css-background-image-hacks/
[2]: https://www.mediawiki.org/wiki/Manual:Interface/IDs_and_classes

Best

Prioritization and scheduling of this bug is tracked on Mingle card https://mingle.corp.wikimedia.org/projects/flow/cards/252

bsitu wrote:

*** This bug has been marked as a duplicate of bug 54252 ***

Change 89249 had a related patch set uploaded by Bsitu:
Notification overlay is partially hidden in RTL language

https://gerrit.wikimedia.org/r/89249

bsitu wrote:

Oops, the patch referenced the wrong bug

This is not needed for all languages.

It is definitely not needed for Hebrew and Yiddish.

It is *probably* needed for all languages written in the Arabic script.

I'm not sure about Divehi (dv) and Aramaic (arc).

Mattflaschen-WMF set Security to None.
EBernhardson triaged this task as Normal priority.Feb 26 2015, 6:45 PM
EBernhardson added a subscriber: EBernhardson.
Restricted Application added a project: Collaboration-Team-Triage. · View Herald TranscriptJun 2 2015, 2:20 PM
Legoktm moved this task from Backlog to Needs plan on the Notifications board.Jul 6 2015, 9:12 AM
Amire80 moved this task from Backlog to Other on the RTL board.Jul 16 2015, 4:50 PM
Restricted Application added a subscriber: Aklapper. · View Herald TranscriptJul 16 2015, 4:50 PM

VisualEditor seems to deal with this issue with the help button (also presented as ?)

It might help checking what lists they have to when to flip the question mark and when not to, and use that same strategy in this case.

Ebraminio moved this task from Other to Echo on the RTL board.Aug 9 2015, 2:34 PM
Jdforrester-WMF closed this task as Resolved.Mar 2 2017, 6:08 AM
Jdforrester-WMF claimed this task.
Jdforrester-WMF added a subscriber: Jdforrester-WMF.

I believe that this is now long-since fixed, since we moved to OOjs UI.