VisualEditor: [Regression] Page settings dialog broken in Firefox
Closed, ResolvedPublic

Description

Current VisualEditor-Version:
commit c98a964d5f8495f0d16af9229abbeb0449042d1e
Merge: 3d01a5b e7aed52
Author: jenkins-bot <jenkins-bot@gerrit.wikimedia.org>
Date: Wed Sep 18 01:11:46 2013 +0000
Merge "Fix check for preformatted when stripping whitespace"

Browser: Firefox 24.0 on Windows 7 64bit

Description:
I updated my VisualEditor via git yesterday. Before that I didnt update for 4 weeks. Now when openening a page on my MediaWiki in VE-Editmode I cant assign a page category (See screenshot).

I tried to debug with Firebug: When I click on categories the following error gets fired:

TypeError: style is null
http://XYZ/load.php?debug=false&lang=de&modules=ext.visualEditor.core%2Cdata%2Cicons-vector%7Cext.visualEditor.viewPageTarget.icons-vector%7Crangy&skin=vector&version=20130919T072806Z&*
Line 9


Version: unspecified
Severity: blocker

bzimport set Reference to bz54322.
Hmrc87 created this task.Via LegacySep 19 2013, 12:46 PM
Krinkle added a comment.Via ConduitSep 19 2013, 12:57 PM

I can confirm. When trying to open the Page settings dialog, an exception is thrown for "style is null":

ve.Element.js, line:

		top = parseFloat( loc ? style.borderTopWidth : $el.css( 'borderTopWidth' ) ) || 0,

Context:
ve.Element.getBorders = function ( el ) {
var doc = el.ownerDocument,

		win = doc.parentWindow || doc.defaultView,
		style = win && win.getComputedStyle ?
			win.getComputedStyle( el, null ) : el.currentStyle,
		loc = win && win.getComputedStyle ? true : false,
		$el = $( el ),
		top = parseFloat( loc ? style.borderTopWidth : $el.css( 'borderTopWidth' ) ) || 0,
gerritbot added a comment.Via ConduitSep 23 2013, 6:01 PM

Change 85692 had a related patch set uploaded by Krinkle:
ve.Element: Account for getComputerStyle returning null

https://gerrit.wikimedia.org/r/85692

gerritbot added a comment.Via ConduitSep 23 2013, 7:19 PM

Change 85692 merged by jenkins-bot:
ve.Element: Account for getComputerStyle returning null

https://gerrit.wikimedia.org/r/85692

Hmrc87 added a comment.Via ConduitSep 24 2013, 5:53 AM

Problem solved. Tested with Firefox 24.0 on Windows 7 64BIT.

Page-settings dialog is operational and working.

Elitre added a comment.Via ConduitOct 3 2013, 11:21 AM

It's still happening, unfortunately. Ed found out it works fine on local and mediawiki.org, though.

TeamGale mentioned this today at en.wp:
<<Just wanted to ask...how can we add categories with VE? In the past I could do it by clicking on "Page settings" but now when I click on it nothing happens! Is there somewhere else a button that adds categories? I searched everywhere but I can't find it. If it's still on the "Page settings" then something is not working right... Thanks TeamGale 09:54, 3 October 2013 (UTC)>>

Fram tested as well:

<<Tested this. FIrst click on "page settings" gives no results. Second click opens the page setting window. But I can't do anything there.>>

I can confirm that the second click just launches an empty window, with only the "categories" label text on the left column.

<<Actually this one with the categories is happening for a while for me. Just when I first found it I was in a hurry and couldn't leave a feedback. Then I totally forgot about it till now that I needed to use it again. It's weird that no one else mentioned it here before though.
Elitre, I don't know if it's a cache problem but I'll try to clean my cache again and re-test it. But the "after a few attempts" is still not right for me. Shouldn't this happening in the first attempt? TeamGale 10:12, 3 October 2013 (UTC)
Update: Nop, still happening the same for me even if I clean cache, cookies etc... TeamGale 10:20, 3 October 2013 (UTC)
Hmm...it seems to be only a Mozilla issue. I just tried it with Mozilla on Greek WP and it still doesn't work. But when I tested it on Google, it was working just fine. TeamGale 11:00, 3 October 2013 (UTC)>>

Krinkle added a comment.Via ConduitOct 3 2013, 4:44 PM

Confirmed:

  • Working on latest master locally (Chrome).
  • Broken on mediawik.org (Chrome).
Catrope added a comment.Via ConduitOct 3 2013, 5:52 PM

This should be fixed in https://gerrit.wikimedia.org/r/#/c/85692 , which is in wmf19 but not in wmf18. enwiki is being upgraded from wmf18 to wmf19 today, hopefully that'll fix it.

Krinkle added a comment.Via ConduitOct 3 2013, 5:59 PM

(In reply to comment #7)

This should be fixed in https://gerrit.wikimedia.org/r/#/c/85692 , which is
in
wmf19 but not in wmf18. enwiki is being upgraded from wmf18 to wmf19 today,
hopefully that'll fix it.

That's the patch that closed this bug (comment 3). But it appears there is indeed a new bug that causes the page settings dialog to be broken again due to an uncaught exception when the dialog is first created when clicking the page settings button.

It fails in Chrome like this:

Uncaught TypeError: Cannot use 'in' operator to search for 'scrollTop' in undefined load.php?…:102
vendorPropName load.php?…:102
jQuery.extend.css load.php?…:105
Tween.propHooks._default.get load.php?…:136
Tween.cur load.php?…:136
Tween.init load.php?…:135
Tween load.php?…:135
Animation.deferred.promise.createTween load.php?…:131
tweeners.* load.php?…:129
(anonymous function) load.php?…:130
jQuery.extend.each load.php?…:8
createTweens load.php?…:130
Animation load.php?…:132
doAnimation load.php?…:137
jQuery.extend.dequeue load.php?…:25
(anonymous function) load.php?…:26
jQuery.extend.each load.php?…:8
jQuery.fn.jQuery.each load.php?…:4
jQuery.fn.extend.queue load.php?…:26
jQuery.fn.extend.animate load.php?…:138
ve.Element.scrollIntoView load.php?ext.visualEditor…:11
ve.Element.scrollElementIntoView load.php?ext.visualEditor…:12
ve.ui.OptionWidget.setSelected load.php?ext.visualEditor…:404
ve.ui.SelectWidget.selectItem load.php?ext.visualEditor…:400
ve.ui.PagedDialog.addPage load.php?ext.visualEditor…:458
ve.ui.MWMetaDialog.initialize load.php?ext.visualEditor…:461
ve.ui.Window.onFrameInitialize load.php?ext.visualEditor…:353
oo.EventEmitter.emit load.php?ext.visualEditor.bas…:133
ve.ui.Frame.load load.php?ext.visualEditor…:351
ve.ui.WindowSet.open load.php?ext.visualEditor…:356
ve.init.mw.ViewPageTarget.onToolbarMwMetaButtonClick load.php?ext.visualEditor.bas…:87
proxy load.php?…:10
jQuery.event.dispatch load.php?…:45
elemData.handle.eventHandle load.php?…:38

Jdforrester-WMF added a comment.Via ConduitOct 3 2013, 6:03 PM

Have split the new failure into bug 54928 and am re-closing this one.

Add Comment